← SMF

Smf e index no google

Lida 4132 vezes

Offline

Viriatu 
Membro
Mensagens 154 Gostos 1
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

Boas

Eu fiz recentemente um forum em SMF a mais de 3 meses, apesar de ja conseguir aparecer em 1º ou 2º pa certas expressoes diz que nao estão paginas indexadas no google ao passo que num Wordpress que fiz a uns dias atras, ja aparecem paginas indexadas... algue me pode ajudar a perceber como e que isto e possivel e como tornar o meu SMF mais "indexavel" no  :procuranogoogle:

cumps
Offline

trmanco 
Membro
Mensagens 163 Gostos 0
Troféus totais: 29
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3 Level 2

Tens de ter uma meta tag no index do SMF parecido com isto -> <META NAME="Robots" CONTENT="index,follow">

Senão coitado dos bots que remédio tem eles em não indexar ou indexar parcialmente o fórum...

Cumps
Offline

Viriatu 
Membro
Mensagens 154 Gostos 1
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

<meta http-equiv="Content-Type" content="text/html; charset=', $context['character_set'], '" />
   <meta name="description" content="', $context['page_title'], '" />', empty($context['robot_no_index']) ? '' : '
   <meta name="robots" content="all, index, follow" />', '
   <meta name="keywords" content="bla bla bla bla " />
   <meta name="allow-search" content="yes">
   <meta name="audience" content="all">

Sera que algo disto esta mal??

no context diz robot_no_index mas creio que isso se refere a nao indexar partes duplicadas no portal... nao tenho a certeza...

sugestões?
Offline

goodsound 
Membro
Mensagens 2485 Gostos 0
Troféus totais: 31
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3

<meta http-equiv="Content-Type" content="text/html; charset=', $context['character_set'], '" />
   <meta name="description" content="', $context['page_title'], '" />', empty($context['robot_no_index']) ? '' : '
   <meta name="robots" content="all, index, follow" />', '
   <meta name="keywords" content="bla bla bla bla " />
   <meta name="allow-search" content="yes">
   <meta name="audience" content="all">

Sera que algo disto esta mal??

no context diz robot_no_index mas creio que isso se refere a nao indexar partes duplicadas no portal... nao tenho a certeza...

sugestões?
Se já adaptaste o código aquilo que percisas, por exemplo as keywords, parece que aí está tudo correcto, logo, agora é esperares que o Google faça oresto.
Offline

trmanco 
Membro
Mensagens 163 Gostos 0
Troféus totais: 29
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3 Level 2

Eu aquela linha a dizer 'robot_no_index' não sei bem o que quer dizer, mas pelos vistos está tudo bem...

Só um pormenor aquelas keywords foste tu que alteraste agora ou está mesmo assim no smf? Se estiver assim muda-as de acordo com o assunto do fórum...
Offline

Viriatu 
Membro
Mensagens 154 Gostos 1
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

Sim tenho keywords relacionadas com o content como e logico isso eu ja tinha feito... so me pareceu estranho ter paginas no index com o wordpress em questao de dias e nada no forum em questão de meses... talvez esteja relacionado com o conteudo dinamico do forum e o facto de levar conteudo novo todos os dias sei la...

cumps
Offline

amaru 
Membro
Mensagens 600 Gostos 0
Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Tens de ter uma meta tag no index do SMF parecido com isto -> <META NAME="Robots" CONTENT="index,follow">

Senão coitado dos bots que remédio tem eles em não indexar ou indexar parcialmente o fórum...

Cumps
Isso é no index.php???
Dentro das tags php dá erro e fora traz algumas bugs na skin :) Estou a fazer com certeza da maneira errada.
Offline

Carlos Gandra 
Administrador
Mensagens 3081 Gostos 97
Feedback +1

Troféus totais: 34
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

No index.template.php, do layout que estiveres a usar ;)

*Já agora uma questão, eu tenho <meta name="robots" content="all" />, faz alguma diferença para o que sugeriste trmanco?
Offline

amaru 
Membro
Mensagens 600 Gostos 0
Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

No index.template.php, do layout que estiveres a usar ;)

*Já agora uma questão, eu tenho <meta name="robots" content="all" />, faz alguma diferença para o que sugeriste trmanco?
Faz o mesmo bug no template Rofl, as letras dos tópicos ficam maiores :lol:
Offline

trmanco 
Membro
Mensagens 163 Gostos 0
Troféus totais: 29
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3 Level 2

No index.template.php, do layout que estiveres a usar ;)

*Já agora uma questão, eu tenho <meta name="robots" content="all" />, faz alguma diferença para o que sugeriste trmanco?

<META NAME="Robots" CONTENT="index,follow" /> é equivalente a <meta name="robots" content="all" />
<META NAME="Robots" CONTENT="noindex,nofollow" /> é equivalente a <meta name="robots" content="none" />

Isto não é CaSe SeNsItIvE, por isso estar em letras maiúsculas a minúsculas não há diferença

Para dizer a verdade prefiro usar index,follow ou seus derivados :P

Offline

Carlos Gandra 
Administrador
Mensagens 3081 Gostos 97
Feedback +1

Troféus totais: 34
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Exacto a minha questão não era no case sensitive mas sim numa eventual diferença entre "all" e "index,follow" ;)

Faz o mesmo bug no template Rofl, as letras dos tópicos ficam maiores :lol:

A sério amaru? É que as meta, no index.template.php, ficam acima do <body>... aliás, elas já lá estão, só tens de as modificar de acordo com o que pretendes, e isso não deve afectar em nada o funcionamento do Fórum ;)
Offline

amaru 
Membro
Mensagens 600 Gostos 0
Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Obrigado.
Mas olha não tinha essas metas no ficheiro tive de adicionar e como agora adicionei logo acima do body como referiste ficou sem bugs :obrigado:
Offline

Carlos Gandra 
Administrador
Mensagens 3081 Gostos 97
Feedback +1

Troféus totais: 34
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Óptimo então ;)