← CMS - Gestores de Conteúdos

ajuda em oscommerce

Lida 5977 vezes

Offline

swing 
Membro
Mensagens 3126 Gostos 41
Feedback +13

Troféus totais: 32
Trófeus: (Ver todos)
Avatar Level 6 Linux User Mobile User Windows User Super Combination Combination Topic Starter Poll Voter Level 5

Olá,

Agradeço a vossa ajuda pois ao instalar a loja oscommerce, mesmo com a versão em português, na parte de criação de conta, ao criar a conta surgem vários países e pretendia que apenas apareça portugal.
Em que parte da loja se podem apagar os outros paises? qual o caminho?

Exemplo duma loja onde esta o que quero:

http://www.jscinformatica.com/create_account.php
Offline

rtbfreitas 
Equipa
Mensagens 1497 Gostos 9
Feedback +24

Troféus totais: 30
Trófeus: (Ver todos)
Windows User Apple User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

viva

não tenho a certeza, mas penso que tens de apagar os países todos que estão na BD, na área admin tem lá uma opção em zonas/impostos e depois países,

cumps
Offline

Santo 
Membro
Mensagens 1657 Gostos 4
Troféus totais: 31
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Se é só para aparecer Portugal, tens de apagar todos os outros paises ou mudar o query sql de modo a escolher apenas Portugal...

Vais à base de dados e vez qual o ID para o pais que queres...

Saudações
Offline

swing 
Membro
Mensagens 3126 Gostos 41
Feedback +13

Troféus totais: 32
Trófeus: (Ver todos)
Avatar Level 6 Linux User Mobile User Windows User Super Combination Combination Topic Starter Poll Voter Level 5

Olá,

Ja aparece apenas portugal, mas agora dá estes erros abaixo :( diz que o mail esta errado e a data de nascimento) quando o cliente envia mail atraves da loja tb n deixa enviar e da o mesmo erro..
Como corrigo isto?

Warning: file(includes/tld.txt) [function.file]: failed to open stream: No such file or directory in /home/favodeme/public_html/loja/includes/functions/validations.php on line 85

Warning: Variable passed to each() is not an array or object in /home/favodeme/public_html/loja/includes/functions/validations.php on line 86

Warning: eregi() [function.eregi]: REG_EMPTY in /home/favodeme/public_html/loja/includes/functions/validations.php on line 97
Offline

Santo 
Membro
Mensagens 1657 Gostos 4
Troféus totais: 31
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Fizeste modificações nos ficheiros? Intalaste algum modulo ou addon?

Saudações
Offline

swing 
Membro
Mensagens 3126 Gostos 41
Feedback +13

Troféus totais: 32
Trófeus: (Ver todos)
Avatar Level 6 Linux User Mobile User Windows User Super Combination Combination Topic Starter Poll Voter Level 5

Não, pedi ao asturmas para me ajudar e diz que apagou os países, ficaram apagados mas hoje ja da esses erros.
Preciso também de ajuda para que apareça uma imagem (de tamanho menor) para o produto e outra( de tamanho maior) quando se clica na opção ampliar imagem na página dos produtos.
Já acontecesse isso com algumas imagens, mas com outras que coloquei agora já não amplia a imagem:(

Obrigado.

Fizeste modificações nos ficheiros? Intalaste algum modulo ou addon?

Saudações
Offline

Santo 
Membro
Mensagens 1657 Gostos 4
Troféus totais: 31
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Isso soa a ficheiros modificados... se fosse a ti enviava os ficheiros originais de novo para o servidor sem mexer na base de dados e nos ficheiros configure.php que estão em /includes e /admin/includes

Saudações
Offline

asturmas 
Administrador
Mensagens 19734 Gostos 49
Feedback +2

Troféus totais: 39
Trófeus: (Ver todos)
Mobile User Windows User Super Combination Combination Topic Starter 100 Poll Votes 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter

Eu apenas apaguei os paises pela base de dados
Offline

Santo 
Membro
Mensagens 1657 Gostos 4
Troféus totais: 31
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Asturmas, não estou a afirmar nada em contrário. Apenas comento que o erro soa a algo modificado que está a causar problemas...Algum mod instalado..?

Saudações
Offline

asturmas 
Administrador
Mensagens 19734 Gostos 49
Feedback +2

Troféus totais: 39
Trófeus: (Ver todos)
Mobile User Windows User Super Combination Combination Topic Starter 100 Poll Votes 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter

Sim eu percebi.
Não nada, tenho de reenviar os ficheiros
Offline

swing 
Membro
Mensagens 3126 Gostos 41
Feedback +13

Troféus totais: 32
Trófeus: (Ver todos)
Avatar Level 6 Linux User Mobile User Windows User Super Combination Combination Topic Starter Poll Voter Level 5

Ainda continua a dar erros, mas o formulario de contacto ja funciona..menos mal, mas a area de criação de conta continua a dar erros..

Outra questão, mudei a cor de fundo e agora a área onde os produtos estão listados tb ficou com a mesma cor..mas não era isso que queria.. queria que onde os produtos estão listados a cor de fundo fosse branca..
axo que é no file styleshett.css mas não sei onde ao certo altero..ja pesquisei sobre o assunto mas td o que alterei não teve efeito..

Ex de uma loja que tem o que quero.

http://www.jsfinformatica.com/index.php?cPath=75_81
Offline

leite 
Membro
Mensagens 864 Gostos 11
Troféus totais: 29
Trófeus: (Ver todos)
Mobile User Apple User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Swing usas o Firebug ?

Se ainda não usares instala e consegues "apanhar" a local exacto para mudar a cor muito facilmente já que consegues testar e editar os ficheiros .css ;)
Offline

Santo 
Membro
Mensagens 1657 Gostos 4
Troféus totais: 31
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Swing,

O plano que contratas-te à ptnet não inclui suporte? Já os contactastes para te ajudarem? Eles melhor que ninguém sabem o que é que instalaram e como instalaram....

Saudações
Offline

swing 
Membro
Mensagens 3126 Gostos 41
Feedback +13

Troféus totais: 32
Trófeus: (Ver todos)
Avatar Level 6 Linux User Mobile User Windows User Super Combination Combination Topic Starter Poll Voter Level 5

Não e da ptnet, eu que instalei.
São apenas exemplos que estou a dar.

Swing,

O plano que contratas-te à ptnet não inclui suporte? Já os contactastes para te ajudarem? Eles melhor que ninguém sabem o que é que instalaram e como instalaram....

Saudações
Offline

Santo 
Membro
Mensagens 1657 Gostos 4
Troféus totais: 31
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

ah ok. peço desculpa pois percebi mal. A sugestão do Leite é excelente para descobrires onde tens de alterar as cores.

Quanto aos erros posta lá aqui o que é que dizem. Não te esqueças de colocar o link que dá o erro.

Saudações