← Joomla

Joomla - Favicon.ico

Lida 9193 vezes

Offline

-RJ- 
Membro
Mensagens 1188 Gostos 0
Troféus totais: 30
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Level 5 Level 4 Level 3

Bem, como o nome do tópico já indica é o raio do favicon.ico do joomla que não sai da-li lol...ou seja, tenho um portal em joomla e já ando a um bom tempo à procura de solução, entre as quais já fiz praticamente de TUDO e o filho da mãe não substitui.

-Já substitui o favicon.ico no public_html e na pasta images;
-Já alterei o nome no painel de configuração do portal;
-Já utilizei a tag
Código: [Seleccione]
<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" /> no index.php do tema até com link directo ao icon e nada;

A verdade é que carrega o favico.ico que quero mas logo a seguir é substituido pelo do Joomla. Isto só no Mozilla/Firefox porque, o IE carrega normalmente o icon sem problemas.

Alguém sabe o que possa ser? :roll:
Offline

BlueEagle 
Membro
Mensagens 2221 Gostos 1
Troféus totais: 31
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3

no IE funca pk ele fez cache  do favicon
nao precisas de meter codigo nenhum
simplesmente substituir o favicon ke esta na pasta: images/ dentro da pasta onde tens o joomla  :wink:
Offline

-RJ- 
Membro
Mensagens 1188 Gostos 0
Troféus totais: 30
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Level 5 Level 4 Level 3

Eu sei mas já fiz isso e obviamente foi a primeira coisa que fiz e já limpei a cache não sei quantas vezes...enfim :S
Offline

leite 
Membro
Mensagens 864 Gostos 11
Troféus totais: 29
Trófeus: (Ver todos)
Mobile User Apple User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Por acaso na configuração global mudas-te o nome do favicon?

Diz-me o nome que tens  lá?
Offline

-RJ- 
Membro
Mensagens 1188 Gostos 0
Troféus totais: 30
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Level 5 Level 4 Level 3

Sim, mudei...

Já experimentei com vários nomes, mas agora pôs o default (favicon.ico).

PS: Quando mudava o nome do icon lá também mudava no nome do ficheiro obviamente.
Offline

BlueEagle 
Membro
Mensagens 2221 Gostos 1
Troféus totais: 31
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3

eu mudei o favicon que estava dentro da pasta IMAGES e ficou tudo ok.
Offline

-RJ- 
Membro
Mensagens 1188 Gostos 0
Troféus totais: 30
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Level 5 Level 4 Level 3

Pois grr :S

Se descobrisse onde ele vai buscar o favicon.ico por deafult (memso o do jommla) e substitui-se esse talvez sim, não haveria mais problemas com ele...acho eu lol :)
Offline

leite 
Membro
Mensagens 864 Gostos 11
Troféus totais: 29
Trófeus: (Ver todos)
Mobile User Apple User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Citação de: "-RJ-"
Sim, mudei...


PS: Quando mudava o nome do icon lá também mudava no nome do ficheiro obviamente.


Pois o que acontecia era que se deixasses o favicon.ico na sitio dele e mudas na conf. geral para outro nome e metias essa imagem no server . Aquilo aparecia-te o favicon do joomla primeiro e depois o teu.

Apenas tens de colocar a tua imagem com o mesmo nome e extensão deixas tudo como estava incialmente ou  seja ,sem introduções de código nem alterações na conf.geral e vai funcionar. ;)
Offline

leite 
Membro
Mensagens 864 Gostos 11
Troféus totais: 29
Trófeus: (Ver todos)
Mobile User Apple User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Citação de: "-RJ-"
Pois grr :S

Se descobrisse onde ele vai buscar o favicon.ico por deafult (memso o do jommla) e substitui-se esse talvez sim, não haveria mais problemas com ele...acho eu lol :)


Exactamente já viste na pasta images do joomla  ?  :P
Offline

BlueEagle 
Membro
Mensagens 2221 Gostos 1
Troféus totais: 31
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3

Citação de: "leite"
Citação de: "-RJ-"
Sim, mudei...


PS: Quando mudava o nome do icon lá também mudava no nome do ficheiro obviamente.


Pois o que acontecia era que se deixasses o favicon.ico na sitio dele e mudas na conf. geral para outro nome e metias essa imagem no server . Aquilo aparecia-te o favicon do joomla primeiro e depois o teu.

Apenas tens de colocar a tua imagem com o mesmo nome e extensão deixas tudo como estava incialmente ou  seja ,sem introduções de código nem alterações na conf.geral e vai funcionar. ;)

exactamente  :)
Offline

-RJ- 
Membro
Mensagens 1188 Gostos 0
Troféus totais: 30
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Level 5 Level 4 Level 3

:x Ta meio lixado...enfim...pôs tudo como vem no inicio e nepia subsitui todos os favicons que encontrei dasss...a unica maneira que funcou no IE fui um ficheiro em png alterada a extensão para .ico e renomedo para icon.ico e depois da configuração global icon.ico...de resto...

Alguma coisa ta a me escapar aqui e não tou a ver o que é... :?
Offline

-RJ- 
Membro
Mensagens 1188 Gostos 0
Troféus totais: 30
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Level 5 Level 4 Level 3

Dá-me pa rir...ele faz o load do favicon correcto e depois aparece o do joomla...isto coisa entre 1,5 segundo...
Offline

leite 
Membro
Mensagens 864 Gostos 11
Troféus totais: 29
Trófeus: (Ver todos)
Mobile User Apple User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

icon.ico ??

-RJ-

o que te está a escapar é que o index.php do template vai buscar o favicon.ico  se não mudares a tua imagem para o nome favicon.ico nunca vais obter o que queres[/b]
Offline

-RJ- 
Membro
Mensagens 1188 Gostos 0
Troféus totais: 30
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Level 5 Level 4 Level 3

Pois...acho que alterei no index...vou ver...secalhar até é :D...dasss
Offline

Nuno 
Administrador
Mensagens 7780 Gostos 216
Feedback +2

Troféus totais: 42
Trófeus: (Ver todos)
100 Poll Votes Level 7 Search Mobile User Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes

Já exprimentas-te fazer refresh à imagem, é capaz de ajudar!