← Desenvolvimento

Como trabalhar com o Wamp5

Lida 4816 vezes

Offline

mCavaleiro 
Membro
Mensagens 74 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 50 Posts

Olá atodos como já umas boas almas  atrás me indicaram este prgrama, aqui vão mais duvidas para alguém me ajudar a resolver, se quiser e souber......

1º Instalei o wamp5, tudo OK......
2º criei um subdirectorio assim: -> c:\wamp5\teste
3º coloquei lá o ficheiro.php
4º no browser fiz -> http:\localhost\ficheiro.php    e NADA

que faço mal?

mais o Wamp5 faz do nosso PC um server.... tipo para alguem aceder ao dito ficheiro.php, a nossa máquina tem de estar ligada?

Desculpem ser tão maçarico mas....... todos temos de começar.....

desde já o meu Obrigado a quem ajudar...... :oops:
Offline

BlueEagle 
Membro
Mensagens 2221 Gostos 1
Troféus totais: 31
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3

dentro da pasta wamp5 deves ter 1 pasta www é ainda dentro ke deves meter os ficheiros  :wink:
Offline

mCavaleiro 
Membro
Mensagens 74 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 50 Posts

Ok dentro dessa pasta www, já existe lá um index.php, mas mesmo esse n abre.
se pretender que um outro ficheiro php abra terei de retirar o que está no www, é isso?

Obrigado BlueEagle

 :lol:
Offline

asturmas 
Administrador
Mensagens 19734 Gostos 49
Feedback +2

Troféus totais: 39
Trófeus: (Ver todos)
Mobile User Windows User Super Combination Combination Topic Starter 100 Poll Votes 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter

Não só tens de la por todos os ficheiros que queres ke abra mas se queres ter 1 index "teu" tiras o ke la esta e poens outro
Offline

mCavaleiro 
Membro
Mensagens 74 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 50 Posts

Ok asturmas, mas e assim ( sou muito burrr....)

instalei o Wamp5  e para estar funcional tem de ( o Put On ) estar ligado, é isso?

depois  ao abrir a janela tem ( Localhost ) (PhpMyAdmin ) ( MySQL ) etc,
que é conforme queira aceder, e isso

tem o APACHE; MYSQL,
dentro de cada uma tem um install terei de instalar alguma coisa mais? ou fica assim

coloquei em c:\wamp5\www um ficheiro email.htm, outro email.php e 4 .gif, para abrir terei no menu do wamp5 de clicar em localhost, abre o browser ai dou a indicação para abrir através do .htm e nada, dou a indicação para abrir o .php e nada, que continuo a fazer mal?

será que preciso de um desenho......
  #-o
Offline

asturmas 
Administrador
Mensagens 19734 Gostos 49
Feedback +2

Troféus totais: 39
Trófeus: (Ver todos)
Mobile User Windows User Super Combination Combination Topic Starter 100 Poll Votes 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter

Nao te posso ajudar pk nunca usei isso mas se queres free host para testar:

alojagratis.org
 8)
Offline

pedrolopes 
Membro
Mensagens 91 Gostos 0
Troféus totais: 23
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1 50 Posts 10 Posts

mCavaleiro,

como aparece o "velocimetro" no tray? tem de estar tudo para a direita...

depois em princípio deveria funcionar ok, nao definiste uma pasta diferença para servir como root na instalação?
Offline

mCavaleiro 
Membro
Mensagens 74 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 50 Posts

Muito Obrigado, AsTurmas

mas já tenho contas no AwardSpace e no freehostia, e n queria muita coisa por aí, depois os portugueses que visitei tipo, ( desculpem a publicidae, GetHost4You) são a meu ver muito picuinhas, por isso é que nós n evoluimos , nem a nós proprios ajudamos.... ) desculpa o desabafo.... mas só quero aprender um pouquinho de php!


Boa  Pedro Lopes

o velocimetro aparece a 25% vermelho e 75% a branco , segundo o que dizes terá de ficar a 100% vermelho, como faço para acontecer isso...

RESOLVIDO o prob, do velocimetro, está a 100%, tudo branco.

Já FUNCIONA.
MUITO obrigado a TODOS !

Agora QUERIA SABER ainda :

Se o Wamp5 faz do nosso PC uma espécie de server.... tipo para alguem aceder ao dito ficheiro.php, a nossa máquina tem de estar ligada?

ou se serve somente para testar, ou se serve para testar e enviar para um ALOJAMENTO que permita o PHP, e se permite geri-lo.......

alguem que saiba e queira ajudar aradeço.


 :roll:
Offline

pedrolopes 
Membro
Mensagens 91 Gostos 0
Troféus totais: 23
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1 50 Posts 10 Posts

podes ir ao no-ip.org e registas-te e ficas com um endereço a apontar para o teu pc por exemplo ;)
Offline

asturmas 
Administrador
Mensagens 19734 Gostos 49
Feedback +2

Troféus totais: 39
Trófeus: (Ver todos)
Mobile User Windows User Super Combination Combination Topic Starter 100 Poll Votes 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter

ja percebi abraços  :D
Offline

verycoolnet 
Membro
Mensagens 4 Gostos 0
Troféus totais: 18
Trófeus: (Ver todos)
Super Combination Combination Level 4 Level 3 Level 2 Level 1 First Post Karma Tenth year Anniversary Nineth year Anniversary

Citação de: "pedrolopes"
podes ir ao no-ip.org e registas-te e ficas com um endereço a apontar para o teu pc por exemplo ;)



boaaas era mesmo disso que eu precisava á tenho wamp e correr ja criei um conta no No-Ip.com e criei um dns host mas nao consigo aceder ao meu site do lado de fora.
agradecia a vossa ajuda
Offline

verycoolnet 
Membro
Mensagens 4 Gostos 0
Troféus totais: 18
Trófeus: (Ver todos)
Super Combination Combination Level 4 Level 3 Level 2 Level 1 First Post Karma Tenth year Anniversary Nineth year Anniversary

Citação de: "pedrolopes"
podes ir ao no-ip.org e registas-te e ficas com um endereço a apontar para o teu pc por exemplo ;)


boass pedro era isso mesmo que eu precisava ja me registei no no-ip e adicionei um host, mas agora sempre tento aceder a minha pagina de fora dá-me este erro
.
403 Forbidden

You don't have permission to access / on this serve

bom espero que me possam ajudar