← Desenvolvimento

Thumbnails e Facebook

Lida 2886 vezes

Offline

Angelicous 
Membro
Mensagens 67 Gostos 0
Troféus totais: 18
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 3 Level 2 Level 1 50 Posts 10 Posts First Post

Boas pessoal,

estou a desenvolver um pequeno blog de entretenimento, e estou com um problema com os thumbnails e o facebook.

O template que estou a usar chama-se "Jarida" e já vem preparado para definir thumbnails. Quando insiro vídeos, eles não aparecem obviamente, e então instalei o plugin "Video Thumbnails" para detectar automáticamente. Ao detectar o video, adiciona também o thumbnail na opção do manual que vem predefinida no template.

O problema é que quando agarro no link de um post, e meto no facebook, não aparece nada. Nem texto, nem thumbnail.

O que é que se poderá estar a passar? :-k

Site: www.porreiropah.com

-----

Já agora será que me podem indicar um tutorial para meter botões de redes sociais mas quadrados em vez destes que estão lá neste momento?

Cumprimentos
Offline

andrevq 
Membro
Mensagens 294 Gostos 19
Troféus totais: 22
Trófeus: (Ver todos)
Level 5 Level 4 Seventh year Anniversary Sixth year Anniversary Super Combination Combination Topic Starter Poll Voter Level 3 Level 2

Usa este código antes de </head>

Código: [Seleccione]
<meta property='og:image' content='LINK_DO_Thumbnail'/>
Troca LINK_DO_Thumbnail por um link para uma imagem, ou por uma Custom Field que o plugin esteja a usar. Ou usas o WordPress SEO by Yoast e bem configurado pode resolver melhor o teu problema. @ http://wordpress.org/plugins/wordpress-seo/ ;)
Offline

Angelicous 
Membro
Mensagens 67 Gostos 0
Troféus totais: 18
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 3 Level 2 Level 1 50 Posts 10 Posts First Post

Já instalei o plugin. Normalmente não configuro nada e ele costuma rodar sem problemas. Não sei que configurações deva fazer :/

Preenchi os campos no artigo, já mudei links e fiz novo post mas não aparece nenhuma info.

A do meta no head não faço ideia qual o link do thumbnail que gera o plugin dos videos
Offline

andrevq 
Membro
Mensagens 294 Gostos 19
Troféus totais: 22
Trófeus: (Ver todos)
Level 5 Level 4 Seventh year Anniversary Sixth year Anniversary Super Combination Combination Topic Starter Poll Voter Level 3 Level 2

No plugin WordPress SEO by Yoast há uma configuração em Social > Frontpage settings > URL da imagem:

Nesse campo, insere um link para uma imagem, o logo do teu blog ou algo parecido. Depois voltas  a fazer uma publicação no facebook, e pelo menos a imagem já deve aparecer.
Offline

Angelicous 
Membro
Mensagens 67 Gostos 0
Troféus totais: 18
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 3 Level 2 Level 1 50 Posts 10 Posts First Post

Nop... Ainda não é desta  :superlol:

Os thumbnails estão definidos, info nos campos do SEO preenchida... Os related post no site aparecem sem problemas... Facebook é que está a falhar qualquer coisa.

Acho que não tenho nenhuma definição no template ou no wordpress a impedir que as imagens sejam usadas
Offline

Angelicous 
Membro
Mensagens 67 Gostos 0
Troféus totais: 18
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 3 Level 2 Level 1 50 Posts 10 Posts First Post

Se alguém puder dar uma olhada dentro, mandem-me PM que mando detalhes para login
Offline

Angelicous 
Membro
Mensagens 67 Gostos 0
Troféus totais: 18
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 3 Level 2 Level 1 50 Posts 10 Posts First Post

Agora estão a dar os dos post :lol: