← WordPress

Problema com a navegação de páginas

Lida 2209 vezes

Offline

amaru 
Membro
Mensagens 600 Gostos 0
Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Boas,
Estou a fazer um site de catalogo para uma loja! e estou com um problema com a 'ZenShop WP Theme'...escolhi o modo "Shop" no "Home page content"...e  na página inicial já tenho 5 páginas de artigos:

O que acontece é que ao clicar nas páginas seguintes, em qualquer uma das cinco, aparece isto:

Estou um pouco enferrujado nisto de fazer sites, alguém pode ajudar?

Obrigado pela vossa atenção!
Offline

Octávio Alves 
Membro
Mensagens 963 Gostos 36
Feedback +25

Troféus totais: 27
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Verifica se as ligações estão a ser feitas para os links correctos.

Cumprimentos
Offline

amaru 
Membro
Mensagens 600 Gostos 0
Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Altero nos ficheiros php? ou no painel administrativo tem como alterar isto? já andei nas ligações permanentes a ver se fazia algo, mas nada.
Offline

amaru 
Membro
Mensagens 600 Gostos 0
Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

O link por exemplo da página 2 é isto:
http://xxx.fariasxxxxxxx.pt/?paged=2
Offline

Luís Salvador 
Membro
Mensagens 2068 Gostos 37
Feedback +4

Troféus totais: 28
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

O que tens no .htaccess?

Faz "update" nas ligações permanentes.
Offline

asturmas 
Administrador
Mensagens 19734 Gostos 49
Feedback +2

Troféus totais: 39
Trófeus: (Ver todos)
Mobile User Windows User Super Combination Combination Topic Starter 100 Poll Votes 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter

Apaga mesmo o .htaccess e vai as ligações permanentes como o Luis disse para ele criar novamente.
Offline

Luís Salvador 
Membro
Mensagens 2068 Gostos 37
Feedback +4

Troféus totais: 28
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Apaga mesmo o .htaccess e vai as ligações permanentes como o Luis disse para ele criar novamente.

Muitos anos a virar frangos lol
Offline

amaru 
Membro
Mensagens 600 Gostos 0
Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Boas tenho isto no .htaccess (após ter eliminado o mesmo como o asturmas disse) e desde já obrigado pelas dicas.
Código: [Seleccione]
# BEGIN WordPress

# END WordPress
O problema persiste!
Offline

Luís Salvador 
Membro
Mensagens 2068 Gostos 37
Feedback +4

Troféus totais: 28
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Então agora faz update às ligações permanentes....

O teu htaccess tem que ter algo como:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress
Offline

amaru 
Membro
Mensagens 600 Gostos 0
Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Após alterar e actualizar...aparece-me isto:
Código: [Seleccione]
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Mas o problema persiste, mas é só nas páginas e na principal, porque depois quando entro em cada marca ao virar páginas está tudo ok, ridiculo!
Offline

Luís Salvador 
Membro
Mensagens 2068 Gostos 37
Feedback +4

Troféus totais: 28
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Algum problema no php, nos ficheiros do template?

Só mesmo vendo...
Offline

amaru 
Membro
Mensagens 600 Gostos 0
Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Estive a ler por ai, acontece com algum pessoal quando actualiza o Wordpress e como esta theme não deve ser recente...
Já eliminei o .htaccess e actualizei nas ligações permanentes e até mudei as permissões depois do .htaccess para 666 e nada [-(
Offline

amaru 
Membro
Mensagens 600 Gostos 0
Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Post editado...