← WordPress

Problemas com PermaLinks

Lida 929 vezes

Offline

Tonif4 
Membro
Mensagens 70 Gostos 0
Troféus totais: 21
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1 50 Posts 10 Posts

Olá pessoal,
Um cliente meu andou a mexer nos links permanentes e não sei o que fez, ao guardar as alterações apareceu o erro 500, impedindo de acessar o blog e o wp-admin.

Entretanto, como é natural, apaguei o .htaccess e o blog ficou acessível na mesma, mas é aí que o estranho se passa.

Ele tentou alterar a estrutura de links de omeusite.com/?p=3 para omeusite/%titulodoartigo%

Entranto, depois de apagar o arquivo .htaccess, todos os artigos apontam já para a nova estrutura de permalinks, no entanto, ao abri-los, deparo-me com o erro 404.

O pior é que quando tento voltar a estruturar os permalinks pelas definições, o erro 500 volta a aparecer, seja qual for a estrutura que eu escolha.

Alguém sabe como resolver?

 :obrigado:
Offline

dioguinho 
Membro
Mensagens 134 Gostos 1
Feedback +1

Troféus totais: 16
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Level 3 Level 2 Level 1 100 Posts 50 Posts 10 Posts First Post

Código: [Seleccione]
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

será isto?
Offline

Tonif4 
Membro
Mensagens 70 Gostos 0
Troféus totais: 21
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1 50 Posts 10 Posts

Pois pah, não sei.

Mas misteriosamente, agora já atualizou.

Não sei se foi problema no servidor, no meu browser (eu limpei a cache, mas nunca se sabe), o que importa é que a partida está tudo bem agora.

Obrigado pela ajuda na mesma!

 :+trafego: