← Desenvolvimento

LocalHost

Lida 1621 vezes

Offline

Vitor Teixeira 
Membro
Mensagens 1527 Gostos 9
Feedback +21

Troféus totais: 28
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Boas,

Eu tenho estado com um problema, não consigo aceder ao localhost com nenhum programa. Já tentei com: EasyPHP, VertrigoServ, Wamp e Xampp e nenhum dá.

A instalação corre bem mas quando acedo a http://localhost fica a carregar e acaba sempre por dar erro. Tentei também usar o IP mas nada. Eu não sei se poderá ser mas a uns tempo a caixa de CD's do meu computador caiu e eu nunca mais a coloquei a funcionar mas duvido que seja disto.

Alguém me pode ajudar?

Abraço!
Offline

Henrique Mouta 
Equipa
Mensagens 1189 Gostos 3
Troféus totais: 31
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3

Se usas skype, fecha-o ;)
O skype usa a porta 80.
Offline

ruicruz 
Membro
Mensagens 1105 Gostos 0
Feedback +1

Troféus totais: 32
Trófeus: (Ver todos)
Apple User Level 6 Super Combination Combination Topic Starter Poll Voter Poll Starter Level 5 Level 4 Level 3

Muda a porta para outra. Provavelmente tens um programa a usar a 80 e não sabes.

Localiza o ficheiro httpd.conf, da um search por listening ou 80, e muda para 81 por exemplo.


Rui
Offline

João Godinho 
Membro
Mensagens 1755 Gostos 2
Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Tive o mesmo problema. Tive de mudar a porta do Skype
Offline

Vitor Teixeira 
Membro
Mensagens 1527 Gostos 9
Feedback +21

Troféus totais: 28
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Como mudaste?
Offline

João Godinho 
Membro
Mensagens 1755 Gostos 2
Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Opções > Avançado > Conexão e desmarca a opção "Usar portas 80 e 443 como alternativa para conexões de entrada"
Offline

Vitor Teixeira 
Membro
Mensagens 1527 Gostos 9
Feedback +21

Troféus totais: 28
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Eu ja nao tenho instalado, pode mesmo assim estar a fazer interferência?

É que ja testei de tudo e nao dá!
Offline

kaydara 
Membro
Mensagens 616 Gostos 1
Feedback +1

Troféus totais: 21
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1 500 Posts 100 Posts

pode ainda ter alguma coisa haver com a caixa de cd's...

Já garantiste que o apache está á escuta ?

Que tipo de erro te dá ? É que o simples não funciona...
Offline

Rob 
Membro
Mensagens 132 Gostos 0
Troféus totais: 22
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Level 4 Level 3 Level 2 Level 1 100 Posts 50 Posts 10 Posts

Começando pelo basico :)

Tens resposta por "localhost" ou nome da maquina?
ping localhost
ping 127.0.0.1

Verifica se serviço na porta 80 responde ou não foi correctamente instalado?
telnet localhost 80
telnet 127.0.0.1 80

Existe alguma coisa a correr sobre a porta 80?
netstat -a -n

Dá erros no arranque do Apache?
Arranca o serviço do Apache com o modo "consola" e/ou verifica o Event Viewer dos erros no arranque.

Para continuar a verificar o problema, já é necessário outro tipo de ferramentas para analisar se o processo do Apache arranca ;)

Process Monitor
http://technet.microsoft.com/en-us/sysinternals/bb896645

Process Explorer
http://technet.microsoft.com/en-us/sysinternals/bb896653


Já agora, já experimentaste instalar o Apache isoladamente para ver se instala o serviço na porta 80 ?