← Desenvolvimento

Ajuda num template (erro no IE6)

Lida 4501 vezes

Offline

Ricardo75 
Membro
Mensagens 1660 Gostos 0
Troféus totais: 28
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Boas  :P
Preciso de ajuda para resolver um problema que se passa no IE 6.
Estava eu a fazer a actualizar o meu template e todo contente com os resultados quando me lembro de o abrir no Internet Explorer. Epá aparecem lá umas coisas que deixaram logo decepcionado  :cry:  mas penso que com a vossa ajuda podem ser de fácil solução.
Tirei 2 screenshots para não terem só que imaginar do que estou a falar:
Firefox (tudo na perfeição)
IE
Reparem naqueles espaços que aparecem por cima do banner e no espaço que aparece por baixo das últimas notícias.
Alguém sabe como resolver isso?

Eu já criei uma nova formatação no css só para colocar nessas células de cima onde pus o padding em 0px, mas não resolveu.
Também já estive a ver e não tem nenhum espaço em nenhuma célula (afinal aprece bem no firefox).

Pode ser útil:
O header tem 9 células 3-3-3
O css não tem erros, pode é estar a faltar alguma coisa  :roll:

Fico aguardando uma resposta vossa e já agora gostava que me dessem uma sugestão, acham que ficava bem perto do escudo Português uma caixa de pesquisa sendo o próprio escudo o botão para pesquisa???

Desde já obrigado!
Offline

MiguelTavares 
Membro
Mensagens 3871 Gostos 0
Troféus totais: 33
Trófeus: (Ver todos)
Avatar Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Tabelas celulas... :roll:

Tenta ver bem aquelas que têm o tamanho em percentagem!!! ;)
Offline

Ricardo75 
Membro
Mensagens 1660 Gostos 0
Troféus totais: 28
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Não me parece ser problemas nos tamanhos porque isso foi das 1ªs coisas que conferi e está tudo em px não em %. MAs mesmo assim vou voltar a conferir.
Obrigado
Offline

MiguelTavares 
Membro
Mensagens 3871 Gostos 0
Troféus totais: 33
Trófeus: (Ver todos)
Avatar Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Talvez com os <div> 's ?

É que eles tambem dão este tipo de problemas... infelizmente!
Offline

fpware 
Fundador
Mensagens 15318 Gostos 6
Troféus totais: 38
Trófeus: (Ver todos)
Linux User Mobile User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5

O MeNz tem toda a razão! Thx MeNz!
Offline

Ricardo75 
Membro
Mensagens 1660 Gostos 0
Troféus totais: 28
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

:oops:  Não tenho qualquer tipo de divs nem spans nem nada disso, é html puríssimo no header.

Aqui fica o código da tabela do header:
Código: [Seleccione]
<table width="780" border="0" align="center" cellpadding="0" cellspacing="0">
<tr>
<td width="147"><img src="<?php echo $mosConfig_live_site;?>/templates/tcmtotal/images/logo_01.jpg" width="147" height="8" /> </td>
    <td width="468" height="8"><img src="<?php echo $mosConfig_live_site;?>/templates/tcmtotal/images/publicidade.png" width="468" height="8" /></td>
    <td width="165"><img src="<?php echo $mosConfig_live_site;?>/templates/tcmtotal/images/logo1_01.jpg" width="165" height="8" /></td>
  </tr>
<tr>
 <td width="147"><img src="<?php echo $mosConfig_live_site;?>/templates/tcmtotal/images/logo_02.jpg" width="147" height="60" /></td>
 <td width="468" height="60"><?php mosLoadModules&#40; 'banner', -1 &#41;; ?></td>
      <td width="165"><img src="<?php echo $mosConfig_live_site;?>/templates/tcmtotal/images/logo1_02.jpg" width="165" height="60" /></td>
  </tr>
<tr>
 <td width="147"><img src="<?php echo $mosConfig_live_site;?>/templates/tcmtotal/images/logo_03.jpg" width="147" height="21" /></td>
 <td height="19" align="center" class="topbar"><?php echo $topbar ?></td>
      <td width="165"><img src="<?php echo $mosConfig_live_site;?>/templates/tcmtotal/images/logo1_03.jpg" width="165" height="21" /></td>
  </tr>
  </tr>
</table>


Hoje não testei mais nenhuma solução, mas pensei numa, talvez se juntasse as 3 células de cima e pusesse uma única imagem duma ponta à outra  :roll:  pode ser que dê... vou tentar isso mais logo.
E por exemplo não sabem de nada semelhante que vos tenha acontecido em que o IE não se tenha dado muito bem com algo deste género. Ainda vou abrir o Frontpage e fazer lá o header, pelo menos no IE não deve aparecer com erros :twisted:

Estou a utilizar divs no módulo do Latest News, mas tem mesmo que ser e ainda vou ter que pôr também no menu direito para que possa desaparecer quando quero. Mas não era suposto os divs darem mais problemas no Firefox que no IE?  :?:

Um abraço!
Offline

Ricardo75 
Membro
Mensagens 1660 Gostos 0
Troféus totais: 28
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Tá tudo resolvido  :D
O IE é todo maluco, mas numa parte tinha toda razão.
A parte de cima apareceia porque tinha um espaço na 1ª célula de cima, mas literalmente um espaço não um &nbsp; não sabia que o IE tomava em atençaõ isso.
O outro era por causa de uma div inútil que andava perdido na tabela do latest news, foi só apagá-lo e ficou a dar. I'm so happy!!!!!!!

Obrigado pela ajuda!!!
Offline

MiguelTavares 
Membro
Mensagens 3871 Gostos 0
Troféus totais: 33
Trófeus: (Ver todos)
Avatar Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Inda bem! :D
Offline

fpware 
Fundador
Mensagens 15318 Gostos 6
Troféus totais: 38
Trófeus: (Ver todos)
Linux User Mobile User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5

Citação de: "Ricardo75"
Tá tudo resolvido  :D
O IE é todo maluco, mas numa parte tinha toda razão.
A parte de cima apareceia porque tinha um espaço na 1ª célula de cima, mas literalmente um espaço não um &nbsp; não sabia que o IE tomava em atençaõ isso.
O outro era por causa de uma div inútil que andava perdido na tabela do latest news, foi só apagá-lo e ficou a dar. I'm so happy!!!!!!!

Obrigado pela ajuda!!!


É o IE lê essa tralha...

divs inúteis aparecem constantemente ;)

Ainda bem que já funca :D
Offline

kebrus 
Membro
Mensagens 459 Gostos 0
Troféus totais: 25
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

ainda bem que já está resolvido, deixo só a nota que o IE e o firefox utilizam as posições de objectos de forma completamente diferente, principalmente quando tentas posicionar um objectos dentro de outro (por exemplo: uma imagem em brackground de uma tabela) isto porque no firefox só aparece bem se puseres o codigo no sitio certo (porque existe milhentas maneiras diferentes de dar caracteristicas a objectos) já no IE é mais desleixado, o problema é que por vezes encontras um sitio é que o codigo funciona no firefox e nao no IE, e vice-versa, o melhor é tentar arranjar um sitio comum nos dois, geralmente eu faço pequenas paginas sem conteudo para testar justamente isso e ver o melhor codigo, aconselho-te a fazer o mesmo quando problemas desses surgirem
Offline

fpware 
Fundador
Mensagens 15318 Gostos 6
Troféus totais: 38
Trófeus: (Ver todos)
Linux User Mobile User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5

O kebrus, como sempre, tem toda a razão ;)
Offline

kebrus 
Membro
Mensagens 459 Gostos 0
Troféus totais: 25
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

Citação de: "fpware"
O kebrus, como sempre, tem toda a razão ;)

lol até parece  :roll:
Offline

Ricardo75 
Membro
Mensagens 1660 Gostos 0
Troféus totais: 28
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Obrigado pelo conselho
Já alguém vos disse que vcês são os maiores  :obrigado:
Offline

Tartaruga 
Membro
Mensagens 2908 Gostos 0
Troféus totais: 29
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3 Level 2

:+trafego:  :ideia:  :orei:
Offline

fpware 
Fundador
Mensagens 15318 Gostos 6
Troféus totais: 38
Trófeus: (Ver todos)
Linux User Mobile User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5

Somos os maiores  :+trafego:  :+trafego:  :+trafego:  :obrigado:  :obrigado:  :obrigado: