← Hosting

Host reclama, eu desespero

Lida 8932 vezes

Offline

mr.max 
Membro
Mensagens 307 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

É a história agora. Preciso mesmo de ajuda aqui, nem que precise de pagar mas preciso de resolver isto.

Bom eu tenho este site, com uma média de 3mil visitantes e 50 membro ativos por dia.

Já faz desde Novembro, que o site tem "picos" de consumo de recursos do servidor, utilizando até 1GB de RAM; 20 processos e 100% CPU, ás vezes isso acontece e nada foi feito no site, coisa que não deixa a host feliz e a mesma enviou já um aviso que não iria deixar renovar o alojamento:
Citar
Após semanas a analisar este problema concluímos que o mesmo se deve ao elevado número de visitantes numa página pouco optimizada para tal. A taxa de utilização média de recursos na sua conta é de tal forma elevada que basta alguma actividade um pouco fora do normal para que a mesma atinja os limites de segurança.

A pergunta é mesmo essa, usando Xenforo, e com os dados que forneci, isso é normal?

Eu até já desativei a maior parte do site para visitantes, já não sei que fazer.
Eu não acho que 3 mil visitas justifiquem tanto consumo só se abrir páginas.

Por favor eu não percebo muito, e preciso mesmo de ajuda, pois não sei primeiro a culpa deste alto consumo, e depois como o diminuir para não ter problemas.

Agradeço qualquer ajuda desde já.
Offline

alopes 
Membro
Mensagens 373 Gostos 8
Feedback -1

Troféus totais: 22
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Level 4 Level 3 Level 2 Level 1 100 Posts 50 Posts 10 Posts

Otimiza o template do fórum, usa um plugin de cache e ativa o cloudflare (caso a empresa de alojamento web ofereça essa opção). Depois de fazeres isso vai ficar mais rápido o site.
Offline

mr.max 
Membro
Mensagens 307 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

Otimiza o template do fórum, usa um plugin de cache e ativa o cloudflare (caso a empresa de alojamento web ofereça essa opção). Depois de fazeres isso vai ficar mais rápido o site.
Cache ativo já, cloudflare quando experimentei causou problemas com os logins por causa do cache. =/
Offline

desbloqueiodetelemoveis 
Membro
Mensagens 457 Gostos 0
Feedback +3

Troféus totais: 20
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1 100 Posts 50 Posts

É a história agora. Preciso mesmo de ajuda aqui, nem que precise de pagar mas preciso de resolver isto.

Bom eu tenho este site, com uma média de 3mil visitantes e 50 membro ativos por dia.

Já faz desde Novembro, que o site tem "picos" de consumo de recursos do servidor, utilizando até 1GB de RAM; 20 processos e 100% CPU, ás vezes isso acontece e nada foi feito no site, coisa que não deixa a host feliz e a mesma enviou já um aviso que não iria deixar renovar o alojamento:
A pergunta é mesmo essa, usando Xenforo, e com os dados que forneci, isso é normal?

Eu até já desativei a maior parte do site para visitantes, já não sei que fazer.
Eu não acho que 3 mil visitas justifiquem tanto consumo só se abrir páginas.

Por favor eu não percebo muito, e preciso mesmo de ajuda, pois não sei primeiro a culpa deste alto consumo, e depois como o diminuir para não ter problemas.

Agradeço qualquer ajuda desde já.

Boas,

Tens o fórum em alojamento partilhado certo?
De facto os picos não se devem as visitas que o fórum tem, mas sim ao seu conteúdo.
O sistema em si (xenforo) é leve, não arcada muito pelo o servidor, digo isso porque já utilizei com algo parecido e não puxa muito pela máquina, em média de 20%
Estes picos devem-se ao conteúdo animado que tens no fórum, e seus plugins.
Ao olhar para o teu fórum encontrei coisas que acho desnecessárias é que poderiam melhor a  estabilidade do servidor e os seus recursos.
Outra coisa que dá cabo dos recursos do servidor é o envio de "avatar" e imagens para o fórum.
E tens esses picos altos devido as visualizações múltiplas das imagens e videos...
Experimenta se quiseres desactivar os videos por 2/3 dias e verás que melhora a situação dos picos..

Mas desde já aconselho-te a mudar o fórum para um servidor dedicado.
Isto porque os plugins instalados, animações, videos e envio de imagens são os que mais "puxam" pelo o servidor..
Se precisares de ajuda no fórum com a transferência, por favor entra em contacto que te ajudo.

Cumps
Offline

mr.max 
Membro
Mensagens 307 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

Boas,

Tens o fórum em alojamento partilhado certo?
De facto os picos não se devem as visitas que o fórum tem, mas sim ao seu conteúdo.
O sistema em si (xenforo) é leve, não arcada muito pelo o servidor, digo isso porque já utilizei com algo parecido e não puxa muito pela máquina, em média de 20%
Estes picos devem-se ao conteúdo animado que tens no fórum, e seus plugins.
Ao olhar para o teu fórum encontrei coisas que acho desnecessárias é que poderiam melhor a  estabilidade do servidor e os seus recursos.
Outra coisa que dá cabo dos recursos do servidor é o envio de "avatar" e imagens para o fórum.
E tens esses picos altos devido as visualizações múltiplas das imagens e videos...
Experimenta se quiseres desactivar os videos por 2/3 dias e verás que melhora a situação dos picos..

Mas desde já aconselho-te a mudar o fórum para um servidor dedicado.
Isto porque os plugins instalados, animações, videos e envio de imagens são os que mais "puxam" pelo o servidor..
Se precisares de ajuda no fórum com a transferência, por favor entra em contacto que te ajudo.

Cumps

Obrigado pela resposta, e sim, partilhado. O sistema de vídeos mesmo sendo só de vídeos youtube, etc.. causa picos, ou estás a falar dos vídeos em posts?
Os álbuns é algo muito utilizado, mas enviar imagens lá é raro, apenas vê-las. Mas isso não tem maneira estando elas hospedadas no servidor ou em outro vai na mesma consumir recursos não é?

Quanto mais visitantes visualizarem esses conteúdos, pior vai ser, por isso que bloqueei o acesso a visitantes.

O problema é que o nosso tipo de membros gosta desse tipo de conteúdos, dai não sei mais especificamente, o que fazer para os poder ter, mas sem causar o caos quando eles são acessados. =/
Mas não posso proibir os users de colocar imagens ou vídeos nos posts, é o que torna o site interessante para eles, tem de existir maneiras de rentabilizar isto.

E falar em rentabilizar, estou longe de conseguir pagar um dedicado, isto parece uma faca encostada à garganta!
Estou feito...
Offline

cenourinha 
Elite
Mensagens 4094 Gostos 21
Troféus totais: 34
Trófeus: (Ver todos)
Mobile User Apple User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4

Já agora, 100% de que CPU? Provavelmente estas num ambiente partilhado em que te é fornecida uma percentagem de utilização do CPU... e estás a utilizar 100% dessa percentagem, agora depende do CPU e do número de cores, etc.
Offline

desbloqueiodetelemoveis 
Membro
Mensagens 457 Gostos 0
Feedback +3

Troféus totais: 20
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1 100 Posts 50 Posts

Obrigado pela resposta, e sim, partilhado. O sistema de vídeos mesmo sendo só de vídeos youtube, etc.. causa picos, ou estás a falar dos vídeos em posts?
Os álbuns é algo muito utilizado, mas enviar imagens lá é raro, apenas vê-las. Mas isso não tem maneira estando elas hospedadas no servidor ou em outro vai na mesma consumir recursos não é?

Quanto mais visitantes visualizarem esses conteúdos, pior vai ser, por isso que bloqueei o acesso a visitantes.

O problema é que o nosso tipo de membros gosta desse tipo de conteúdos, dai não sei mais especificamente, o que fazer para os poder ter, mas sem causar o caos quando eles são acessados. =/
Mas não posso proibir os users de colocar imagens ou vídeos nos posts, é o que torna o site interessante para eles, tem de existir maneiras de rentabilizar isto.

E falar em rentabilizar, estou longe de conseguir pagar um dedicado, isto parece uma faca encostada à garganta!
Estou feito...

Boas,

Falei dos videos youtube que tens, e nos posts..
Eu sei que assim que fechares as aplicações mais "interessantes" eles deixem de visitar o fórum.
Ao visualizar as imagens no fórum estamos a receber a imagem seja ela pequena ou grande, e ao mudares o directório das imagens para outro servidor por exemplo, será uma solução, mas depois no futuro terás mais uma dor de cabeça com isso.
Podes sempre tentar mudar para uma vps, conheço algumas de valor baixo...e fazeres tipo "comparação" dos recursos, mas não irás notar muitas melhoras..
O ideal seria mesmo um dedicado, conheço alguns a 50€ +/- e para começar é um preço razoável..
Mas tu agora é que sabes..
Offline

desbloqueiodetelemoveis 
Membro
Mensagens 457 Gostos 0
Feedback +3

Troféus totais: 20
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1 100 Posts 50 Posts

Já agora, 100% de que CPU? Provavelmente estas num ambiente partilhado em que te é fornecida uma percentagem de utilização do CPU... e estás a utilizar 100% dessa percentagem, agora depende do CPU e do número de cores, etc.

Sim ele está num ambiente partilhado.
E ele atinge o máximo da CPU..
Offline

Nuno 
Administrador
Mensagens 7780 Gostos 215
Feedback +2

Troféus totais: 42
Trófeus: (Ver todos)
100 Poll Votes Level 7 Search Mobile User Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes

Já te explicaram os problemas noutro post.
Offline

alopes 
Membro
Mensagens 373 Gostos 8
Feedback -1

Troféus totais: 22
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Level 4 Level 3 Level 2 Level 1 100 Posts 50 Posts 10 Posts

Podes experimentar usar uma solução de cloud files para alojar os ficheiros de imagens na cloud ou então usar uma VPS.
Offline

cenourinha 
Elite
Mensagens 4094 Gostos 21
Troféus totais: 34
Trófeus: (Ver todos)
Mobile User Apple User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4

Sim ele está num ambiente partilhado.
E ele atinge o máximo da CPU..

A questão é... que percentagem de CPU está ele a utilizar? Ele pode estar num servidor com um Intel Xeon Six-Core... mas ter apenas alocado 10% de um core e estar a utilizar 100% desses 10% de core. Espero que me tenhas percebido :)

O melhor será analisar também os logs do servidor e verificar o que é que está a provocar esse consumo de recursos. Instalar o xenforo de raiz (theme default sem plugins/addons/mods) e analisar os resultados, também pode resultar.
Offline

mr.max 
Membro
Mensagens 307 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

Já agora, 100% de que CPU? Provavelmente estas num ambiente partilhado em que te é fornecida uma percentagem de utilização do CPU... e estás a utilizar 100% dessa percentagem, agora depende do CPU e do número de cores, etc.
Segundo o que dizem não me devo preocupar com o CPU, mas sim com a memória e os processos.

Boas,

Falei dos videos youtube que tens, e nos posts..
Eu sei que assim que fechares as aplicações mais "interessantes" eles deixem de visitar o fórum.
Ao visualizar as imagens no fórum estamos a receber a imagem seja ela pequena ou grande, e ao mudares o directório das imagens para outro servidor por exemplo, será uma solução, mas depois no futuro terás mais uma dor de cabeça com isso.
Podes sempre tentar mudar para uma vps, conheço algumas de valor baixo...e fazeres tipo "comparação" dos recursos, mas não irás notar muitas melhoras..
O ideal seria mesmo um dedicado, conheço alguns a 50€ +/- e para começar é um preço razoável..
Mas tu agora é que sabes..

Ao bloquear o acesso aos conteúdos pelos visitantes, estou a diminuir as vezes que esses conteúdos serão acessados, isso acaba sendo bom dessa forma.
Depois, neste momento nem VPS nem Dedicado me é possível, já que acabaria por ter que sair do meu bolso e mais cedo ou mais tarde iam existir problemas suportar os custos. = /
E hospedar imagens em outro servidor, isso não seria, grátis pois não?
Offline

desbloqueiodetelemoveis 
Membro
Mensagens 457 Gostos 0
Feedback +3

Troféus totais: 20
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1 100 Posts 50 Posts

A questão é... que percentagem de CPU está ele a utilizar? Ele pode estar num servidor com um Intel Xeon Six-Core... mas ter apenas alocado 10% de um core e estar a utilizar 100% desses 10% de core. Espero que me tenhas percebido :)

O melhor será analisar também os logs do servidor e verificar o que é que está a provocar esse consumo de recursos. Instalar o xenforo de raiz (theme default sem plugins/addons/mods) e analisar os resultados, também pode resultar.

Percebi cenourinha :)
Sim é uma hipótese ele instalar o fórum de raiz.
Eu próprio usei durante 7 meses e nunca me consumida mais de 25% e tinha quase o número de visitas igual a ele.
Mas não tinha videos nem albúns como ele tem..
Ele também tem imagens animadas...que é do inicio uma coisa que ele nunca deveria ter colocado..
Offline

mr.max 
Membro
Mensagens 307 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

A questão é... que percentagem de CPU está ele a utilizar? Ele pode estar num servidor com um Intel Xeon Six-Core... mas ter apenas alocado 10% de um core e estar a utilizar 100% desses 10% de core. Espero que me tenhas percebido :)

O melhor será analisar também os logs do servidor e verificar o que é que está a provocar esse consumo de recursos. Instalar o xenforo de raiz (theme default sem plugins/addons/mods) e analisar os resultados, também pode resultar.
Eles dizem que mesmo a 100% estou a usar uma pequena percentagem do total do CPU do servidor. Agora com 7 pessoas online, está entre os 20% a 70% o load, o consumo da memoria de 2 a 40% e de processos chega aos 5.
Offline

desbloqueiodetelemoveis 
Membro
Mensagens 457 Gostos 0
Feedback +3

Troféus totais: 20
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1 100 Posts 50 Posts

Segundo o que dizem não me devo preocupar com o CPU, mas sim com a memória e os processos.

Ao bloquear o acesso aos conteúdos pelos visitantes, estou a diminuir as vezes que esses conteúdos serão acessados, isso acaba sendo bom dessa forma.
Depois, neste momento nem VPS nem Dedicado me é possível, já que acabaria por ter que sair do meu bolso e mais cedo ou mais tarde iam existir problemas suportar os custos. = /
E hospedar imagens em outro servidor, isso não seria, grátis pois não?

Podes sempre tentar alojar as imagens num alojamento partilhado..
Mas como tens muitas imagens, o problema em vez de ser num host iria ser em 2 hosts.
Visto teres imagens superiores a 1,5MB..