← Hosting

Este consumo dos recursos do servidor é normal?!

Lida 4862 vezes

Offline

mr.max 
Membro
Mensagens 307 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

Olá.

Enfim, o meu site já faz algum tempo que tem dados erros e chega aos limites de Memória, Processos e CPU várias vezes por dia.

Com um limite de 1GB de memoria, estou num servidor partilhado com um fórum Xenforo com uma média de 3mil visitantes diários, uma média de 50 online, com 2mil membros e 100 mil postagens.



Essa imagem foi o que a minha host me passou, é isso normal?!

Ou será que algo está errado e a consumir mais do que deve?


É porque eu acho que com os números que tem a querer mais de 1GB de memória...
Digam o que acham e sugestões para ajudar a aguentar o site o melhor possível.

Max  :)
Offline

mr.max 
Membro
Mensagens 307 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

Eu só para testar coloquei o site em manutenção, o load do servidor não sai dos 40%-100%!

A Host disse que esse gráfico é referido APENAS à minha conta.

Eu só tenho esse site ativo, que tipo de bruxaria é esta? --'
Offline

Jóni Oliveira 
Administrador
Mensagens 3427 Gostos 391
Feedback +28

Troféus totais: 35
Trófeus: (Ver todos)
Tenth year Anniversary Nineth year Anniversary Mobile User Apple User Level 6 Windows User Super Combination Combination Topic Starter 10 Poll Votes

Eu só para testar coloquei o site em manutenção, o load do servidor não sai dos 40%-100%!

A Host disse que esse gráfico é referido APENAS à minha conta.

Eu só tenho esse site ativo, que tipo de bruxaria é esta? --'

Verifica todo o conteúdo que tens alojado sem ser só o fórum. Já verificaste o error_log como disseram ontem?
Offline

Nuno 
Administrador
Mensagens 7780 Gostos 215
Feedback +2

Troféus totais: 42
Trófeus: (Ver todos)
100 Poll Votes Level 7 Search Mobile User Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes

Qual é o site?
Offline

mr.max 
Membro
Mensagens 307 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

Verifica todo o conteúdo que tens alojado sem ser só o fórum. Já verificaste o error_log como disseram ontem?

Ontem onde? Eu já verfiquei tudo, apaguei tudo o que não é necessário, subdomínios, base de dados, ficheiros, agora é só o fórum, no qual no log vejo alguns erros mas é na base coisas com um ou outro addon que acontecem uma vez por outra.

Os erros que encontro no cPanel:

[Mon Dec 26 16:48:57 2011] [error] [client ----------] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/zyppy85/public_html/---/index.php, referer: http://---/threads/frases-que-eu-nunca-direi.2037/page-2

Isso é certamente falta de memória, com 1GB de memoria --'.
Offline

mr.max 
Membro
Mensagens 307 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

Offline

Nuno 
Administrador
Mensagens 7780 Gostos 215
Feedback +2

Troféus totais: 42
Trófeus: (Ver todos)
100 Poll Votes Level 7 Search Mobile User Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes

Aposto o meu dinheiro nisto.

Se queres usar essa coisa feia, faz-lo a partir do teu servidor e não a fazer hotlinking de outro site...

PS: Na imagem podes ver o tempo que isso está a fazer o teu site demorar a carregar...


Offline

mr.max 
Membro
Mensagens 307 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

Aposto o meu dinheiro nisto.

Se queres usar essa coisa feia, faz-lo a partir do teu servidor e não a fazer hotlinking de outro site...

PS: Na imagem podes ver o tempo que isso está a fazer o teu site demorar a carregar...

Wow, nem fui eu que criei os ranks de CSS, mas é essa imagem a culpada de todos os meus problemas? Se não for, qual o teu NIB?
Offline

Jóni Oliveira 
Administrador
Mensagens 3427 Gostos 391
Feedback +28

Troféus totais: 35
Trófeus: (Ver todos)
Tenth year Anniversary Nineth year Anniversary Mobile User Apple User Level 6 Windows User Super Combination Combination Topic Starter 10 Poll Votes

Wow, nem fui eu que criei os ranks de CSS, mas é essa imagem a culpada de todos os meus problemas? Se não for, qual o teu NIB?

Está a causar lentidão sim, mas quanto à memória RAM...

Com o NIB do Nuno não fazes nada, a não ser mandar-lhe €€ Lol
Offline

mr.max 
Membro
Mensagens 307 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

Está a causar lentidão sim, mas quanto à memória RAM...

Com o NIB do Nuno não fazes nada, a não ser mandar-lhe €€ Lol
Mudei a imagem, o CPU Load no cPanel está nos 20% a 70% mantendo-se nos 50% na média, com 90~ online pelo site...

O que acho engraçado é que ele fica com CPU Load a 100% e numa lentidão enorme, ás vezes com apenas 10 online no site, é isso que me dá a volta à cabeça,  o consumo dos recursos devia ser mais alto quando está mais gente. --'
Offline

mr.max 
Membro
Mensagens 307 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

Aconteceu de novo!

Ninguém faz nada, nos logs estão apenas vendo tópicos na maioria, mas do nada acontece isto:


1, 2 segundos depois volta ao normal, mas são esses picos de consumo de recursos do servidor que não entendo!
Offline

GhostMaster 
Membro
Mensagens 1374 Gostos 0
Feedback +10

Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 1000 Posts

A licença do Xenforo é original? Aposto que é isto...
Offline

mr.max 
Membro
Mensagens 307 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

A licença do Xenforo é original? Aposto que é isto...

Já temos mais de 1 ano a usar o Xenforo, nada disso. Aliás este problema do load começou à volta de 1 mês mesmo, já falei com a host mesmo para saber o que acontece nesses picos de consumo dos recursos do servidor...
Offline

asturmas 
Administrador
Mensagens 19734 Gostos 49
Feedback +2

Troféus totais: 39
Trófeus: (Ver todos)
Mobile User Windows User Super Combination Combination Topic Starter 100 Poll Votes 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter

Se não tens erros são utilizadores a mais para um utilizador partilhado e tens sorte te darem 1GB de memoria RAM.. No entanto e seguindo a ideia do Nuno, faz-te mossa colocares durante 1 dia por exemplo o forum com o theme original e testar?
Offline

cenourinha 
Elite
Mensagens 4094 Gostos 21
Troféus totais: 34
Trófeus: (Ver todos)
Mobile User Apple User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4

O problema está aparentemente relacionado com o site e não com o alojamento, como acontece na maioria das vezes.

De qualquer forma, deverás questionar o teu host relativamente ao CPU do servidor, cores alocados e percentagem de utilização permitida.

Muitos dos erros do error_log podem ser gerados já depois da conta de alojamento ter atingido os limites, não tendo mais memória para processar a informação, como é o caso do erro que indicaste acima.

Aparentemente o teu site atinge também várias vezes o limite de processos.