← Conversa Geral

Nova actualização do phpbb

Lida 7371 vezes

Offline

BL4CKIC3 
Membro
Mensagens 3439 Gostos 0
Troféus totais: 32
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3

Foi lançado hoje a versão 2.0.12 do phpBB. Essa versão corrige inúmeras vulnerabilidades.

Ressaltamos a importância de atualizarem seus fóruns o mais rápido possível, para que corrijam todas as vulnerabilidades já conhecidas.

Mudanças na versão 2.0.12

Added confirm table to admin_db_utilities.php

Prevented full path display on critical messages

Fixed full path disclosure in username handling caused by a PHP 4.3.10 bug - AnthraX101

Added exclude list to unsetting globals (if register_globals is on) - SpoofedExistence

Fixed arbitrary file disclosure vulnerability in avatar handling functions - AnthraX101

Fixed arbitrary file unlink vulnerability in avatar handling functions - AnthraX101

Removed version number from powered by line

Merged database update files to update_to_latest.php file

Fixed path disclosure bug in search.php caused by a PHP 4.3.10 bug (related to AnthraX101's discovery)

Fixed path disclosure bug in viewtopic.php caused by a PHP 4.3.10 bug - matrix_killer
Offline

fpware 
Fundador
Mensagens 15318 Gostos 6
Troféus totais: 38
Trófeus: (Ver todos)
Linux User Mobile User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5

Muito obrigado pelo aviso BL4CKIC3 :D
Offline

fpware 
Fundador
Mensagens 15318 Gostos 6
Troféus totais: 38
Trófeus: (Ver todos)
Linux User Mobile User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5

Feito :D
Offline

MiguelTavares 
Membro
Mensagens 3871 Gostos 0
Troféus totais: 32
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3

Como posso fazer o upgrade sem ter de reinstalar os MODS/HACKS todos de novo?

Alguem me poderá dizer?
Offline

fpware 
Fundador
Mensagens 15318 Gostos 6
Troféus totais: 38
Trófeus: (Ver todos)
Linux User Mobile User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5

Fiz o que está aqui e não tive de reinstalar nada:

http://www.phpbb.com/phpBB/viewtopic.php?t=265444
Offline

MiguelTavares 
Membro
Mensagens 3871 Gostos 0
Troféus totais: 32
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3

Muitoooo obrigado :orei:

Vou já tratar do assunto!!! :D
Offline

fpware 
Fundador
Mensagens 15318 Gostos 6
Troféus totais: 38
Trófeus: (Ver todos)
Linux User Mobile User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5

Sempre às ordens MeNz, depois diz como correu.
Offline

MiguelTavares 
Membro
Mensagens 3871 Gostos 0
Troféus totais: 32
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3

Correu tudo sobre rodas! ;)

Já está a bombar!!! :D
Offline

justangel 
Membro
Mensagens 922 Gostos 1
Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

:cry:  eu fiz o download do phpbb 12 (Changed Files Only) fiz o overwrite dos ficheiros, e depois finalmente quando quero correr o "update_to_latest.php" aparece-me isto  :shock:

Código: [Seleccione]
Warning: main(./../extension.inc): failed to open stream: No such file or directory in /home/cinetuga/public_html/update_to_latest.php on line 46

Warning: main(./../extension.inc): failed to open stream: No such file or directory in /home/cinetuga/public_html/update_to_latest.php on line 46

Warning: main(): Failed opening './../extension.inc' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/cinetuga/public_html/update_to_latest.php on line 46

Warning: main(./../config.): failed to open stream: No such file or directory in /home/cinetuga/public_html/update_to_latest.php on line 47

Warning: main(./../config.): failed to open stream: No such file or directory in /home/cinetuga/public_html/update_to_latest.php on line 47

Warning: main(): Failed opening './../config.' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/cinetuga/public_html/update_to_latest.php on line 47
Please read: INSTALL.html before attempting to update.


epa comigo estas coisas nunca correm bem  :?
Offline

justangel 
Membro
Mensagens 922 Gostos 1
Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

a linha 46 é
Código: [Seleccione]
include($phpbb_root_path . 'extension.inc');

e a 47
Código: [Seleccione]
include($phpbb_root_path . 'config.'.$phpEx);

 :? n percebo nada disto...
Offline

fpware 
Fundador
Mensagens 15318 Gostos 6
Troféus totais: 38
Trófeus: (Ver todos)
Linux User Mobile User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5

Citação de: "justangel"
:cry:  eu fiz o download do phpbb 12 (Changed Files Only) fiz o overwrite dos ficheiros, e depois finalmente quando quero correr o "update_to_latest.php" aparece-me isto  :shock:

Código: [Seleccione]
Warning: main(./../extension.inc): failed to open stream: No such file or directory in /home/cinetuga/public_html/update_to_latest.php on line 46

Warning: main(./../extension.inc): failed to open stream: No such file or directory in /home/cinetuga/public_html/update_to_latest.php on line 46

Warning: main(): Failed opening './../extension.inc' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/cinetuga/public_html/update_to_latest.php on line 46

Warning: main(./../config.): failed to open stream: No such file or directory in /home/cinetuga/public_html/update_to_latest.php on line 47

Warning: main(./../config.): failed to open stream: No such file or directory in /home/cinetuga/public_html/update_to_latest.php on line 47

Warning: main(): Failed opening './../config.' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/cinetuga/public_html/update_to_latest.php on line 47
Please read: INSTALL.html before attempting to update.


epa comigo estas coisas nunca correm bem  :?


lol

Tens de colocar o ficheiro: "update_to_latest.php" dentro de um directório chamado "install"
Offline

fpware 
Fundador
Mensagens 15318 Gostos 6
Troféus totais: 38
Trófeus: (Ver todos)
Linux User Mobile User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5

Citação de: "justangel"
a linha 46 é
Código: [Seleccione]
include($phpbb_root_path . 'extension.inc');

e a 47
Código: [Seleccione]
include($phpbb_root_path . 'config.'.$phpEx);

 :? n percebo nada disto...


Isso não tem qq problema, desde que edites a linha certa ;)

Pode ter sido algum mod que acrescentou qq coisa ao código.
Offline

justangel 
Membro
Mensagens 922 Gostos 1
Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

pois, e agora como faço? ja fiz o overwrite do ficheiros so me faltava essa parte...  :?
Offline

fpware 
Fundador
Mensagens 15318 Gostos 6
Troféus totais: 38
Trófeus: (Ver todos)
Linux User Mobile User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5

Citação de: "justangel"
pois, e agora como faço? ja fiz o overwrite do ficheiros so me faltava essa parte...  :?


Citar
Tens de colocar o ficheiro: "update_to_latest.php" dentro de um directório chamado "install"
Offline

ViiPER 
Membro
Mensagens 1208 Gostos 1
Troféus totais: 29
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Citação de: "justangel"
pois, e agora como faço? ja fiz o overwrite do ficheiros so me faltava essa parte...  :?

o fpware ja te respondeu:
Tens de colocar o ficheiro: "update_to_latest.php" dentro de um directório chamado "install"