← SMF

SMF 1.1.13, SMF 2.0 RC4 Security Patch, and SMF 2.0 Release Candidate 5

Lida 4480 vezes

Offline

Nuno 
Administrador
Mensagens 7780 Gostos 215
Feedback +2

Troféus totais: 42
Trófeus: (Ver todos)
100 Poll Votes Level 7 Search Mobile User Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes

This version is a security release, and it is strongly advised that all users upgrade to this release as it contains a few security and privacy fixes in both SMF 2.0 and SMF 1.1.

Main points of this 2.0 release include:
Several security-related fixes.
Mail management fixed.
Issues with international forums characters.
Unread replies and topics core functionalities issues were fixed.
A few administration features issues were fixed.
New integration hooks features introduced in RC4 were fixed.
Many other fixes and improvements.


http://www.simplemachines.org/community/index.php?topic=421547.0
Offline

JoseOliveira 
Membro
Mensagens 526 Gostos 4
Troféus totais: 30
Trófeus: (Ver todos)
Linux User Mobile User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3

"Ocorreu um erro com a instalação do pacote
Pelo menos um erro foi encontrado durante o teste de instalação deste pacote. É recomendado que não continue com a instalação a não ser que saiba aquilo que está a fazer, e tenha feito um backup recentemente. Este erro pode ter sido causado por um conflito entre o pacote que está a tentar instalar e outro pacote que esteja instalado, ou tenha ocorrido um erro no pacote, ou o pacote que esta a tentar instalar necessita de outro pacote que não tem instalado, ou então o pacote não é para esta versão do SMF."

./Sources/QueryString.php   Falha

Devo continuar?
Offline

Nuno 
Administrador
Mensagens 7780 Gostos 215
Feedback +2

Troféus totais: 42
Trófeus: (Ver todos)
100 Poll Votes Level 7 Search Mobile User Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes

Não...

Tens um mod que está a causar um erro na instalação. Ou removes o mod ou instalas manualmente.
Offline

JoseOliveira 
Membro
Mensagens 526 Gostos 4
Troféus totais: 30
Trófeus: (Ver todos)
Linux User Mobile User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3

Nunca me dei muito bem com o SMF... por isso deixo algumas questões que podem ajudar outros também.

Como instalo manualmente? (copio os ficheiros substituindo ou edito?)
Se remover o mod, será que ainda o poderei reinstalar, recuperando o que ele fazia (por exemplo o pretty urls, ad management,...)?
Offline

Carlos Gandra 
Administrador
Mensagens 3081 Gostos 97
Feedback +1

Troféus totais: 34
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Viva,

Uma vez que estás a ter problemas apenas no QueryString.php, só tens de instalar manualmente as modificações para esse ficheiro.

Segundo estes detalhes, edita esse ficheiro da seguinte forma:

Encontra
Código: [Seleccione]
* =============================================================================== *
* Software Version: SMF 1.1.9 *

Substitui por
Código: [Seleccione]
* =============================================================================== *
* Software Version: SMF 1.1.13 *

Encontra
Código: [Seleccione]
// Now make absolutely sure it's a number.
$board = (int) $_REQUEST['board'];

Substitui por
Código: [Seleccione]
// Now make absolutely sure it's a number.
$board = (int) $_REQUEST['board'];
$_REQUEST['start'] = isset($_REQUEST['start']) ? (int) $_REQUEST['start'] : 0;

Encontra
Código: [Seleccione]
// There should be a $_REQUEST['start'], some at least. If you need to default to other than 0, use $_GET['start'].
if (empty($_REQUEST['start']) || $_REQUEST['start'] < 0)

Substitui por
Código: [Seleccione]
// There should be a $_REQUEST['start'], some at least. If you need to default to other than 0, use $_GET['start'].
if (empty($_REQUEST['start']) || $_REQUEST['start'] < 0 || (int) $_REQUEST['start'] > 2147473647)

Os restantes ficheiros, se não falham, podes fazer pelo automático.
Offline

tbk22 
Membro
Mensagens 1268 Gostos 0
Troféus totais: 29
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3 Level 2

FML... ainda ha 2 ou 3 dias tinha feito a manutenção toda aos meus forums...

Tanto codigo misturado que vou ter de fazer uma instalação limpa que os MODs com tanta versao ja nem andam a instalar como deve de ser
Offline

easynote 
Membro
Mensagens 87 Gostos 0
Troféus totais: 21
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1 50 Posts 10 Posts

Tá a demorar a chegar à 2.0 final :D
Offline

tbk22 
Membro
Mensagens 1268 Gostos 0
Troféus totais: 29
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3 Level 2

Tá a demorar a chegar à 2.0 final :D

Com a organização daquela equipa ja nem sei se chega
Offline

easynote 
Membro
Mensagens 87 Gostos 0
Troféus totais: 21
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1 50 Posts 10 Posts

Com a organização daquela equipa ja nem sei se chega

Isso é que era pena. Vamos indo e vamos vendo :)
Offline

nram 
Membro
Mensagens 777 Gostos 0
Feedback +1

Troféus totais: 28
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Com a organização daquela equipa ja nem sei se chega
Meteram-se também com o wiki :S ... Podiam ter terminado o Fórum...
Offline

Carlos Gandra 
Administrador
Mensagens 3081 Gostos 97
Feedback +1

Troféus totais: 34
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Ainda em relação ao QueryString, tive o mesmo problema em todos os fóruns 1.1 que actualizei devido ao mod pretty urls.

A solução é simples:

 - Desinstalar o Pretty Urls
 - Instalar a actualização
 - Instalar a última versão do Pretty Urls (1.0 RC5)

Offline

nram 
Membro
Mensagens 777 Gostos 0
Feedback +1

Troféus totais: 28
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Uma coisa, quando temos por exemplo a default theme noutra pasta dá para fazer UPGRADE? é que quando eu tento fazer dá barraca, e suspeito que é por não ter a pasta Themes, acho que no repair_settings faça o que fizer ele não liga...
Offline

nram 
Membro
Mensagens 777 Gostos 0
Feedback +1

Troféus totais: 28
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

O RC4 Security = RC5?
Para fazer o upgrade do 4 para o 5 é necessário ser à lá pata? é que não me apetecia nada ter que voltar a instalar os mod todos à pata! :/
Offline

rodobalho 
Membro
Mensagens 14 Gostos 0
Troféus totais: 16
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Level 3 Level 2 Level 1 10 Posts First Post Karma Seventh year Anniversary

viva,

eu estou a começar um fórum agora, acham que deva optar pela versão 1.1.13 ou 2.0? se criar 1.1.13 depois será mais difícil fazer o update para a fazer final do 2.0 certo?

cumprimentos
Offline

Carlos Gandra 
Administrador
Mensagens 3081 Gostos 97
Feedback +1

Troféus totais: 34
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Se estás a começar opta pelo 2.0. Esta versão RC5 é a 2.0 final, apenas ainda não oficialmente (por questões de burocracia ou algo do género...)

O RC4 Security = RC5?

Não. Inclui as actualizações de segurança do RC5, mas não as funcionalidades.