← SMF

Fórum Offline

Lida 3305 vezes

Offline

Consultor 
Membro
Mensagens 812 Gostos 10
Feedback +21

Troféus totais: 24
Trófeus: (Ver todos)
Level 5 Windows User Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1

Boas, espero que me possam ajudar sff

No fórum smf fui ao  menu " Features and Options " - "Layout and Options" e desactivei a opção    " Enable who's online list " e agora cada vez que tento aceder ao fórum aparece a seguinte mensagem :

  Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.


Como posso fazer para reparar isto, visto que nem consigo entrar na parte admin?

Obrigado
Cumps
Offline

cenourinha 
Elite
Mensagens 4094 Gostos 21
Troféus totais: 34
Trófeus: (Ver todos)
Mobile User Apple User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4

Acede ao phpmyadmin e faz um repair na base de dados e verifica se no Settings.php está tudo correcto.
Offline

Consultor 
Membro
Mensagens 812 Gostos 10
Feedback +21

Troféus totais: 24
Trófeus: (Ver todos)
Level 5 Windows User Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1

Acede ao phpmyadmin e faz um repair na base de dados e verifica se no Settings.php está tudo correcto.

Desculpa a minha ignorância mas para fazer o que dizes tenho que aceder aos ficheiros pelo o servidor não é? E já agora este erro é normal por ter desactivado aquela função?

Obrigado
Offline

Carlos Gandra 
Administrador
Mensagens 3081 Gostos 97
Feedback +1

Troféus totais: 34
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Para acederes ao phpmyadmin faz o seguinte:

1. Entra no cPanel com os teus dados (username e senha)
2. Dentro dele clica no ícone PhpMyAdmin
3. À esquerda clica no nome da base de dados do fórum
4. Selecciona as tabelas todas e em baixo escolhe Reparar (ou Repair se tiver em inglês)

Normal, normal nenhum erro é ;) E também pode não ter sido causado por essa desactivação e ser uma mera coincidência.
Offline

Consultor 
Membro
Mensagens 812 Gostos 10
Feedback +21

Troféus totais: 24
Trófeus: (Ver todos)
Level 5 Windows User Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1


Cenourinha e Ac99 Obrigado pelas respostas.


Ac99 vou seguir as tuas dicas a ver se consigo consertar o fórum

 :obrigado:
Offline

Carlos Gandra 
Administrador
Mensagens 3081 Gostos 97
Feedback +1

Troféus totais: 34
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Ok depois diz qualquer coisa, se conseguiste, etc ;)
Offline

Consultor 
Membro
Mensagens 812 Gostos 10
Feedback +21

Troféus totais: 24
Trófeus: (Ver todos)
Level 5 Windows User Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1

Ok depois diz qualquer coisa, se conseguiste, etc ;)

Segui os teus passos, mas continua o erro :(

Será que existe outra forma?
Offline

Paulo Gil 
Membro
Mensagens 233 Gostos 0
Troféus totais: 25
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

Alteras-te recentemente alguma informação na base de dados do fórum ?

Offline

Carlos Gandra 
Administrador
Mensagens 3081 Gostos 97
Feedback +1

Troféus totais: 34
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Tal como o cenourinha disse, vê no teu Settings.php se alguma informação está errada, ou então usa o repair_settings para verificar se está tudo correcto na configuração ;)

What is repair_settings?

Se fosse a ti procurava também saber se isso não é problema de alojamento. Já falaste com eles? ;)
Offline

Consultor 
Membro
Mensagens 812 Gostos 10
Feedback +21

Troféus totais: 24
Trófeus: (Ver todos)
Level 5 Windows User Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1

Alteras-te recentemente alguma informação na base de dados do fórum ?



Não, só fiz mesmo o que mencionei na primeira mensagem..

Se eu instalar outra vez o fórum e usar um backup que fiz recentemente perco os tópicos,user etc..?
Offline

Consultor 
Membro
Mensagens 812 Gostos 10
Feedback +21

Troféus totais: 24
Trófeus: (Ver todos)
Level 5 Windows User Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1

Tal como o cenourinha disse, vê no teu Settings.php se alguma informação está errada, ou então usa o repair_settings para verificar se está tudo correcto na configuração ;)

What is repair_settings?

Se fosse a ti procurava também saber se isso não é problema de alojamento. Já falaste com eles? ;)

Do alojamento não é os outros sites alojados lá está tudo ok..
Vou tentar fazer o que dizes, quanto settings.php já estive a ver e pareceu-me tudo certo embora não seja um pró no assunto
Offline

Carlos Gandra 
Administrador
Mensagens 3081 Gostos 97
Feedback +1

Troféus totais: 34
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Do alojamento não é os outros sites alojados lá está tudo ok..

Isso não quer dizer nada, se estiveres num serviço fraco ou de overselling, as conexões à base de dados são mais limitadas e o SMF pode estar a "sofrer" com isso ;)