← WordPress

sidebar fugiu !!!

Lida 2414 vezes

Offline

moedas 
Membro
Mensagens 57 Gostos 0
Troféus totais: 22
Trófeus: (Ver todos)
Windows User Linux User Mobile User Super Combination Combination Topic Starter Level 4 Level 3 Level 2 Level 1

Olá pessoal

Mais uma vez preciso de ajuda de profissionais. A sidebar do meu site fugiu-me para baixo dos posts, não me lembro de lhe fazer nada.

Podem-me explicar o que se terá passado???

Agradeço a vossa ajuda :+trafego:
Offline

Shaddz 
Membro
Mensagens 2324 Gostos 2
Feedback +9

Troféus totais: 29
Trófeus: (Ver todos)
Windows User Linux User Mobile User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4

ajudava se dissesses o site
Offline

moedas 
Membro
Mensagens 57 Gostos 0
Troféus totais: 22
Trófeus: (Ver todos)
Windows User Linux User Mobile User Super Combination Combination Topic Starter Level 4 Level 3 Level 2 Level 1

OK, peço desculpa, o site é o:

http://www.kloucas.com/
Offline

cjseven 
Administrador
Mensagens 1809 Gostos 26
Feedback +3

Troféus totais: 28
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 1000 Posts

diminui o padding do logo ou o tamanho do mesmo e ficas com o problema resolvido
Offline

betanalista 
Membro
Mensagens 2564 Gostos 0
Feedback +18

Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

tipo as cenas não fogem aqui no mundo webmaster  :-k

o problema é o que o cjseven referiu, pois o menu esta fora do sitio, se depois do menu tivesses um "clear:both;" possivelmente não fugia a sidebar só desalinhava o menu  :grin:
Offline

Pedro Lopes 
Beta tester
Mensagens 3568 Gostos 18
Feedback +6

Troféus totais: 32
Trófeus: (Ver todos)
Level 6 Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3

Se não mexeste em nada ultimamente, então o problema é nos artigos.

Vai desactivando um a um para ver se é mesmo problema de algum. Se for vê o que tens no conteudo, deve ter alguma div por fechar ou algo assim.
Offline

moedas 
Membro
Mensagens 57 Gostos 0
Troféus totais: 22
Trófeus: (Ver todos)
Windows User Linux User Mobile User Super Combination Combination Topic Starter Level 4 Level 3 Level 2 Level 1

Antes de mais agradeço a vossa ajuda.

Citar
Se não mexeste em nada ultimamente, então o problema é nos artigos.

Vai desactivando um a um para ver se é mesmo problema de algum. Se for vê o que tens no conteudo, deve ter alguma div por fechar ou algo assim.

Sem estar a menosprezar as indicações do cjseven e do betanalista, que foram igualmente importantes, segui o raciocínio do Pedro lopes, porque realmente como não tinha mexido no código só poderia ser dos posts.

Mas após de ter suspendido os últimos posts o problema continuava, e então percebi que tinha introduzido uma nova categoria no menu, e foi essa nova categoria que fez com que a sidebar "fugisse".

Agora pergunto-vos como posso introduzir essa nova categoria sem que me aconteça o mesmo problema?
Offline

betanalista 
Membro
Mensagens 2564 Gostos 0
Feedback +18

Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

tens de aumentar o tamanho do menu na no código css

mas pelo que vi tu tens definido no css o tamanho de "width:960px;" e não defeniste o alinhamento do menu a direita logo devia estar a esquerda.

Por isso mantenho a minha opinião e a do cjseven, o logo esta demasiado grande e esta a "empurrar" o menu para o lado. Experimenta meter um logo muito mais pequeno e vê se o menu das categorias vai para a esquerda


ou então põe no teu ficheiro css

Código: [Seleccione]
.clear {
clear:both;
}

e depois mete no header antes de
Código: [Seleccione]
<div id="categorymenu">
isto:
Código: [Seleccione]
<div class="clear"></div>

se o menu descer mas ficar alinhado a esquerda é o logo que esta muito grande
Offline

betanalista 
Membro
Mensagens 2564 Gostos 0
Feedback +18

Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

no segundo caso:

também pode ficar tudo no sitio porque eu acho que não andas a limpar os floats  :wink:
Offline

cjseven 
Administrador
Mensagens 1809 Gostos 26
Feedback +3

Troféus totais: 28
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 1000 Posts

No style.css, linha 47, substitui:

#branding .logo {
padding:40px 0;
}

por

#branding .logo {
padding:20px 0;
}

E ficas com o problema resolvido (é no fundo o que indiquei anteriormente)

Dica: Usa o firefox e instala o firebug - não há melhor para resolver estes detalhes.

Fica o seguinte vídeo como prova ;)

http://www.screencast.com/users/AntonioAlmeida/folders/Jing/media/d2da17a7-3cee-494f-8095-4e7dd927f1bc
Offline

moedas 
Membro
Mensagens 57 Gostos 0
Troféus totais: 22
Trófeus: (Ver todos)
Windows User Linux User Mobile User Super Combination Combination Topic Starter Level 4 Level 3 Level 2 Level 1

Antes de mais queria agradecer ao betanalista e ao cjseven pela ajuda preciosa que me deram, pois consegui, uma vez mais resolver o problema.

Citar
mas pelo que vi tu tens definido no css o tamanho de "width:960px;" e não defeniste o alinhamento do menu a direita logo devia estar a esquerda.

De facto o logo parecia estar muito grande, então peguei na indicação do betanalista e diminui o logo para 760px.

Citar
No style.css, linha 47, substitui:

#branding .logo {
padding:40px 0;
}

por

#branding .logo {
padding:20px 0;
}

Depois fiz o que o cjseven indicou, diminui também o padding para 20px e consegui desta forma resolver o problema da sidebar que "fugia" :lol:


Mais uma vez  :obrigado:
Offline

betanalista 
Membro
Mensagens 2564 Gostos 0
Feedback +18

Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

esse tamanho 960px era o tamanho que tinhas definido como o comprimento permitido para a largura do menu, ou seja consegues criares links no menu ate atingires os 960px, depois disso passa para a linha de baixo e fica desconfigurado, essa largura estava bem porque é a largura do tema, vi que mudaste para 760px, mas a minha intenção não era que alterasses era sim tentar te explicar que o menu estava fora do sitio, logo por causa de algo que estava mal configurado acima dele  :wink:

por isso é que disse para diminuireis o tamanho do logo e ias ver como o menu ia ao sitio, por acaso não vi como estava o css referente ao logo, mas o cjven viu e muito bem e viu que tinhas um padding demasiado grande.


Resumidamente:
- Aconselho-te a voltares a por os 960px sempre tens mais espaço para o menu
- Assunto resolvido  :-P
Offline

moedas 
Membro
Mensagens 57 Gostos 0
Troféus totais: 22
Trófeus: (Ver todos)
Windows User Linux User Mobile User Super Combination Combination Topic Starter Level 4 Level 3 Level 2 Level 1

Citar
Resumidamente:
- Aconselho-te a voltares a por os 960px sempre tens mais espaço para o menu
- Assunto resolvido 

Ok, recoloquei outra vez o tamanho para os 960px, mantendo o padding nos 20px, como o cjseven referiu, e de facto o problema ficou resolvido. O menu encontra-se alinhado á esquerda e não é empurrado para baixo.  :grin:

 :obrigado: