← Joomla

mysqli

Lida 1981 vezes

Offline

Roberto Francisco 
Membro
Mensagens 669 Gostos 1
Feedback +3

Troféus totais: 28
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Boas, alguém sabe como posso "mudar" uma bd para mysqli, instalei um componente e dá-me esta mensagem de erro:

Koowa plugin requires MySQLi Database Driver. Please change your database configuration settings to 'mysqli'

Alguém me pode ajudar?

abraço,
Offline

Santo 
Membro
Mensagens 1657 Gostos 4
Troféus totais: 31
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

MySQLi é um modulo compilado no apache/php e não uma aplicação. Ou suporta ou não. Para além do PHP o programa também tem de suportar o mysqli (i de improved)

Saudações
Offline

Roberto Francisco 
Membro
Mensagens 669 Gostos 1
Feedback +3

Troféus totais: 28
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Como é que ponho isto a funcionar? :-?
Offline

Santo 
Membro
Mensagens 1657 Gostos 4
Troféus totais: 31
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Perguntas:

1 - Tens acesso root ao servidor ou VPS ou apenas uma conta de alojamento?

2 - O programa/script em causa usa ou suporta mysqli, certo?

Saudações
Offline

Roberto Francisco 
Membro
Mensagens 669 Gostos 1
Feedback +3

Troféus totais: 28
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Estou neste momento a usar o wampp e no phpmyadmin refere o msqli, o script dá aquela mensagem de erro...
Offline

Santo 
Membro
Mensagens 1657 Gostos 4
Troféus totais: 31
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

O script suporta o MySQLi?

Tens de compilar o mysqli como modulo no PHP.

Depois fazes um php -i e verificas se o mysqli está na lista de modulos carregados.