← SMF

SMF mods problemas de instalação recorrentes

Lida 2334 vezes

Offline

smiths 
Membro
Mensagens 101 Gostos 0
Feedback +2

Troféus totais: 21
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Level 4 Level 3 Level 2 Level 1 100 Posts 50 Posts 10 Posts

Viva,

Estou com problemas a instalar mods (qualquer um) no SMF, embora num caso já tenha conseguido.

As permissões estão correctas e segui os passos para instalar com php safe mode on... mesmo assim não dá.

Nas definições do plesk o php safe mode está on e julgo que não consigo alterar directamente (corrija-me se estiver enganado). Estou a ponderar solicitar ao host para alterar aquele parâmetro a ver se resolvo o problema.

Quem usa SMF costuma ter php safe mode off? Existe algum risco acrescido em termos de segurança?

Desde já obrigado pela atenção
Offline

Nuno 
Administrador
Mensagens 7780 Gostos 216
Feedback +2

Troféus totais: 42
Trófeus: (Ver todos)
100 Poll Votes Level 7 Search Mobile User Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes

O que é que o safe mode do php tem a ver com a instalação de mods?! Em principio nada, so se for algum mod específico que necessite do safe mod, mas em principio não é isso que trás problemas na instalação de mods.

Podes mostrar o erro que te dá a instalar?
Offline

smiths 
Membro
Mensagens 101 Gostos 0
Feedback +2

Troféus totais: 21
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Level 4 Level 3 Level 2 Level 1 100 Posts 50 Posts 10 Posts

Viva Nuno,



Este é o erro que surge sempre em qualquer mod. Referi o php safe mode por causa desta thread:
http://www.simplemachines.org/community/index.php?topic=229297.0

Obrigado

 
Offline

Nuno 
Administrador
Mensagens 7780 Gostos 216
Feedback +2

Troféus totais: 42
Trófeus: (Ver todos)
100 Poll Votes Level 7 Search Mobile User Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes

Pois se for esse o problema, das duas uma. Ou pedes ao teu host para mudar a configuração do safe mode, ou tentas esse tutorial. Se bem que esse tutorial é um "pain in the ass!"...

PS: As boas empresas de alojamento geralmente preocupam-se se a suas configurações são compatíveis com os cms mais populares...
Offline

STronic 
Elite
Mensagens 546 Gostos 8
Feedback +5

Troféus totais: 30
Trófeus: (Ver todos)
Mobile User Search Apple User Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3

Eu tive alguns problemas identicos com um host nacional e o problema tinha a ver com permissões de pastas, uma vez que eles tinham um script que passava tudo (expecto o que definiam nesse script) a 644 nas permissoes de ficheiros... nem por FTP conseguia alterar...
Tive que indicar "tintim por tintim" todos os ficheiros que queria a 755 ou 777...

A mim só me dava isso quando tentava "escrever" em algum ficheiro.... poderá nao ser o teu problema (pelo install.xml que aparece no prtsc)