← WordPress

erro ao usar no link www

Lida 969 vezes

Offline

betanalista 
Membro
Mensagens 2564 Gostos 0
Feedback +18

Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

bem ainda estou a construir um site mas ele agora esta a dar-me um erro

quando uso http://nomesite.com/site ele fundiona bem
se coloco http://www.nomedosite.com/site da o seguinte erro:




função com o bloco de codigo da linha 866:

Código: [Seleccione]
function wp_redirect($location, $status = 302) {
global $is_IIS;

$location = apply_filters('wp_redirect', $location, $status);
$status = apply_filters('wp_redirect_status', $status, $location);

if ( !$location ) // allows the wp_redirect filter to cancel a redirect
return false;

$location = wp_sanitize_redirect($location);

if ( $is_IIS ) {
header("Refresh: 0;url=$location");
} else {
if ( php_sapi_name() != 'cgi-fcgi' )
status_header($status); // This causes problems on IIS and some FastCGI setups
header("Location: $location", true, $status);
}
}
endif;


linha 866:

Código: [Seleccione]
if ( php_sapi_name() != 'cgi-fcgi' )
Offline

betanalista 
Membro
Mensagens 2564 Gostos 0
Feedback +18

Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

problema esta resolvido

tinha dado um <Enter> no ficheiro wp-header antes do codigo php que o mesmo contem e parece que isso estava a originar o erro