← WordPress

Imagens não aparecem

Lida 1687 vezes

Offline

Fernando Augusto 
Membro
Mensagens 923 Gostos 0
Feedback +1

Troféus totais: 30
Trófeus: (Ver todos)
Linux User Mobile User Windows User Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3

Criei um sub-domínio e instalei o wordpress no mesmo, só que as imagens, quer no painel de admin quer no blogue não aparecem.

Offline

Ricardo75 
Membro
Mensagens 1660 Gostos 0
Troféus totais: 28
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

O url e caminho do blog está correcto nas configurações?

Já tentaste usar a função do firefox "Ver imagem" ou "Ver imagem de fundo" e ver qual o url que aparece?
Offline

Fernando Augusto 
Membro
Mensagens 923 Gostos 0
Feedback +1

Troféus totais: 30
Trófeus: (Ver todos)
Linux User Mobile User Windows User Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3

http://videos.dragonball-pt.info/wp-content/themes/default/images/kubrickheader.jpg/

Aprecem assim, sempre com o / no final

Já instalei pelo installatron e depois manualmente e fica sempre assim
Offline

Ricardo75 
Membro
Mensagens 1660 Gostos 0
Troféus totais: 28
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Já reparaste que não tens imagens no directório das imagens do tema? #-o
http://videos.dragonball-pt.info/wp-content/themes/default/images/
Offline

Fernando Augusto 
Membro
Mensagens 923 Gostos 0
Feedback +1

Troféus totais: 30
Trófeus: (Ver todos)
Linux User Mobile User Windows User Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3

O ftp discorda e o file manager do cpanel discordam.

Offline

Ricardo75 
Membro
Mensagens 1660 Gostos 0
Troféus totais: 28
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Epá, esquisito. Já me está a ultrapassar...

Tens algum ficheiro .htaccess no directório principal do wp? Se sim coloca aqui o conteúdo sff.
Offline

Fernando Augusto 
Membro
Mensagens 923 Gostos 0
Feedback +1

Troféus totais: 30
Trófeus: (Ver todos)
Linux User Mobile User Windows User Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3

pois...

Código: [Seleccione]
RewriteEngine on
Options All Indexes
IndexOptions -FancyIndexing

# BEGIN WPSuperCache
<IfModule mod_rewrite.c>
RewriteBase /
AddDefaultCharset UTF-8
RewriteCond %{REQUEST_URI} !^.*[^/]$
RewriteCond %{REQUEST_URI} !^.*//.*$
RewriteCond %{REQUEST_METHOD} !=POST
RewriteCond %{QUERY_STRING} !.*=.*
RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
RewriteCond %{HTTP_user_agent} !^.*(Android|2.0\ MMP|240x320|AvantGo|BlackBerry|Blazer|Cellphone|Danger|DoCoMo|Elaine/3.0|EudoraWeb|hiptop|IEMobile|iPhone|iPod|KYOCERA/WX310K|LG/U990|MIDP-2.0|MMEF20|MOT-V|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Opera\ Mini|Palm|Playstation\ Portable|portalmmm|Proxinet|ProxiNet|SHARP-TQ-GX10|Small|SonyEricsson|Symbian\ OS|SymbianOS|TS21i-10|UP.Browser|UP.Link|Windows\ CE|WinWAP).*
RewriteCond %{HTTP:Accept-Encoding} gzip
RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz [L]

RewriteCond %{REQUEST_URI} !^.*[^/]$
RewriteCond %{REQUEST_URI} !^.*//.*$
RewriteCond %{REQUEST_METHOD} !=POST
RewriteCond %{QUERY_STRING} !.*=.*
RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
RewriteCond %{HTTP_user_agent} !^.*(Android|2.0\ MMP|240x320|AvantGo|BlackBerry|Blazer|Cellphone|Danger|DoCoMo|Elaine/3.0|EudoraWeb|hiptop|IEMobile|iPhone|iPod|KYOCERA/WX310K|LG/U990|MIDP-2.0|MMEF20|MOT-V|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Opera\ Mini|Palm|Playstation\ Portable|portalmmm|Proxinet|ProxiNet|SHARP-TQ-GX10|Small|SonyEricsson|Symbian\ OS|SymbianOS|TS21i-10|UP.Browser|UP.Link|Windows\ CE|WinWAP).*
RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html [L]
</IfModule>

# END WPSuperCache

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

RewriteCond %{HTTP_REFERER} !^http://dragonball-pt.info/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http://dragonball-pt.info$      [NC]
RewriteCond %{HTTP_REFERER} !^http://forum.dragonball-pt.info/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http://forum.dragonball-pt.info$      [NC]
RewriteCond %{HTTP_REFERER} !^http://www.dragonball-pt.info/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http://www.dragonball-pt.info$      [NC]
RewriteCond %{HTTP_REFERER} !^http://www.dragonball-pt.info/forum/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http://www.dragonball-pt.info/forum$      [NC]
RewriteCond %{HTTP_REFERER} !^http://video.dragonball-pt.info/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http://video.dragonball-pt.info$      [NC]
RewriteCond %{HTTP_REFERER} !^http://www.dragonball-pt.info/video/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http://www.dragonball-pt.info/video$      [NC]
RewriteRule .*\.(.*jpg|jpeg|gif|png|bmp|swf)$ - [F,NC]

Offline

Fernando Augusto 
Membro
Mensagens 923 Gostos 0
Feedback +1

Troféus totais: 30
Trófeus: (Ver todos)
Linux User Mobile User Windows User Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3

Já funciona, o endereço no .htaccess estava errado.

Obrigado!