← WordPress

Envio de Imagens

Lida 1222 vezes

Offline

AnaMartelo 
Administrador
Mensagens 2071 Gostos 25
Feedback +28

Troféus totais: 29
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Bem, é do conhecimento geral que ainda sou muito azelha nestas lides... LOl
Então sempre que tenho dúvidas pergunto, mas eu estou a tentar aprender, prometo!

Então é o seguinte, desde que me iniciei no mundo dos blogs (depois de perder o meu primeiro blog por estupidez) que sempre que tento adicionar uma foto a um blog pelo Wordpress a imagem não fica .. :S Fica apenas uma cruz vermelha, então eu faço sempre o upload directamente para o FTP e depois adiciono por URL no wordpress. Mas isso dá uma trabalheira desnecessaria se tudo tivesse a funcionar bem...

Com o conselho do Roberto Francisco falei com o meu provedor do serviço de alojamento para ver se o problema era deles e ao que tive a resposta para fazer umas mudanças ...

Ora então passo a explicar..

Aceder ao CPanel e no Gerenciamento de Arquivos e mudar as permissoes.. para 7 7 7 !
Ora eu fiz isso e quando isso acontece dá-me erro para entrar nos blogs e nao consigo fazer nada.. Logo "desfiz" as mudanças e mantive-me igual na esperança que me podessem ajudar..

Será.. :\
Offline

Typhoon 
Membro
Mensagens 94 Gostos 0
Troféus totais: 22
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1 50 Posts 10 Posts

Podes fazer Chmod 755 ou 775 (o 777 é meio perigoso  :superlol:) através do teu cliente FTP. Em principio deve ser só isso. Muitas vezes que faço o CHMOD pelo file manager do cpanel não são mesmo aplicadas as permissões.
Offline

Celso Azevedo 
Membro
Mensagens 3500 Gostos 38
Feedback +12

Troféus totais: 30
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Vai a http://www.OTEUSITE.com/wp-admin/options-misc.php

e vê se o "Armazenar ficheiros enviados nesta pasta" está correcto:



O user "Shaddz" disse por aqui num tópico que resolveu o problema corrigindo o "caminho" para a pasta.

Testa e depois diz qualquer coisa  :cool:
Offline

AnaMartelo 
Administrador
Mensagens 2071 Gostos 25
Feedback +28

Troféus totais: 29
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Obrigado Pessoal! :)

Penso que está a funcionar já :D