← Blogging/Comunidades

[WP-domínio] Problema

Lida 3573 vezes

Offline

Tobito 
Membro
Mensagens 57 Gostos 0
Troféus totais: 23
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 4 Level 3 Level 2 Level 1 50 Posts

Instalei o wordpress e até aqui tudo bem. Mas acontece que o meu blog ficou localizado em www.*site*.com/wordpress e a única forma de conseguir que o domínio correspondesse ao site em si foi ao fazer um redireccionamento de www.*site*.com para www.*site*.com/wordpress. Sem este redireccionamento, ao aceder ao blog, recebo simplesmente uma página em branco com as directorias do lado esquerdo.

Agradeço a quem me tentar ajudar.
Offline

Vitor Teixeira 
Membro
Mensagens 1527 Gostos 9
Feedback +21

Troféus totais: 28
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Se instalares pelo fantastico:



Se instalaste por algum FTP na pasta do Wordpress mandas só os ficheiros que lá estão dentro.

Espero ter ajudado.
Offline

Shaddz 
Membro
Mensagens 2324 Gostos 1
Feedback +9

Troféus totais: 29
Trófeus: (Ver todos)
Windows User Linux User Mobile User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4

vai a opções- geral e Endereço WordPress (URL) - lá deve estar http://www.dominio.com tira o "www." [da opção debaixo faz a mesma coisa]
Offline

Tobito 
Membro
Mensagens 57 Gostos 0
Troféus totais: 23
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 4 Level 3 Level 2 Level 1 50 Posts

Se instalares pelo fantastico:



Se instalaste por algum FTP na pasta do Wordpress mandas só os ficheiros que lá estão dentro.

Espero ter ajudado.
Exacto, mas acontece que preferia ter tudo organizado por pastas e não queria mover os ficheiros para a raiz.
Entretanto estive a ler tutoriais mas continuo sem conseguir: eliminei o redireccionamento, copiei o htaccess e o index.php para a raiz e mudei uma linha do index.php... Continuo com o problema que tinha.

Já agora o tutorial está aqui: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

E não consigo perceber o que é suposto fazer ao ler isto: (On linux, use mkdir wordpress from your www directory. You'll probably want to use "chown apache:apache" on the wordpress directory you created.)
Offline

Vitor Teixeira 
Membro
Mensagens 1527 Gostos 9
Feedback +21

Troféus totais: 28
Trófeus: (Ver todos)
Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Nunca exprimentei por como está ai,fiz sempre como te disse em cima.
Offline

Tobito 
Membro
Mensagens 57 Gostos 0
Troféus totais: 23
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 4 Level 3 Level 2 Level 1 50 Posts

Desisti de tentar seguir o tut e resolvi simplesmente passar tudo para a raiz. Mas agora recebo erros internos, ajuda? lol
Offline

Shaddz 
Membro
Mensagens 2324 Gostos 1
Feedback +9

Troféus totais: 29
Trófeus: (Ver todos)
Windows User Linux User Mobile User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4

Desisti de tentar seguir o tut e resolvi simplesmente passar tudo para a raiz. Mas agora recebo erros internos, ajuda? lol

o domínio tava a redireccionar para /pasta , tens de por o domínio a redireccionar para onde tens os ficheiros e provavelmente também vais ter que mudar algumas coisas no ficheiro wp-config
Offline

Tobito 
Membro
Mensagens 57 Gostos 0
Troféus totais: 23
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 4 Level 3 Level 2 Level 1 50 Posts

o domínio tava a redireccionar para /pasta , tens de por o domínio a redireccionar para onde tens os ficheiros e provavelmente também vais ter que mudar algumas coisas no ficheiro wp-config

O redireccionamento já apaguei. O que é que tenho de mudar no wp-onfig?
Offline

Shaddz 
Membro
Mensagens 2324 Gostos 1
Feedback +9

Troféus totais: 29
Trófeus: (Ver todos)
Windows User Linux User Mobile User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4

tudo o que tem public_html/pasta/ficheiros
 metes public_html/ficheiros
Offline

Tobito 
Membro
Mensagens 57 Gostos 0
Troféus totais: 23
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 4 Level 3 Level 2 Level 1 50 Posts

Mas o ficheiro wp-config não tem nada disso.

Nvm problema resolvido.

Uma última questão; porque é que quando clico no título ou nos comments de um post vou parar a uma pagina not found (dentro do blog)?
Offline

ruicruz 
Membro
Mensagens 1105 Gostos 0
Feedback +1

Troféus totais: 32
Trófeus: (Ver todos)
Apple User Level 6 Super Combination Combination Topic Starter Poll Voter Poll Starter Level 5 Level 4 Level 3

Porque, ainda tens que alterar nas configurações o domínio para nao ter a /pasta/.

Se estás confortável com MySQL podes também fazer uma pesquisa na tabela config pela palavra /pasta (a tua pasta) e alterar os campos à mão no phpMyAdmin.

Se não, faz só o que te disse em cima que deve resolver.


SL
Offline

Tobito 
Membro
Mensagens 57 Gostos 0
Troféus totais: 23
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 4 Level 3 Level 2 Level 1 50 Posts

Disso não é de certeza, desinstalei o wordpress e voltei a instalar mas na raíz. O meu problema agora é que mesmo no blog, consigo ler posts e ver os anúncios etc o que leva a pensar que está tudo bem. Mas para responder a um post ou a abrir um post já me da erro de Page nor Found, mas não dá uma página de erro... simplesmente vou parar à primeira página do blog com o tal Page not Found no título. Escusado será dizer que abrindo os posts que estão na sidebar como Recentes, vai dar o mesmo erro.

Ainda pensei que fosse algum problema com as slugs, mas não deve ser porque parece-me estar tudo bem.
Offline

ruicruz 
Membro
Mensagens 1105 Gostos 0
Feedback +1

Troféus totais: 32
Trófeus: (Ver todos)
Apple User Level 6 Super Combination Combination Topic Starter Poll Voter Poll Starter Level 5 Level 4 Level 3

Cria um .htaccess com isto:

Código: [Seleccione]
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>


Resolveu?


SL
Offline

Tobito 
Membro
Mensagens 57 Gostos 0
Troféus totais: 23
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 4 Level 3 Level 2 Level 1 50 Posts

Esse ficheiro com esses parâmetros já tinha.
Offline

ruicruz 
Membro
Mensagens 1105 Gostos 0
Feedback +1

Troféus totais: 32
Trófeus: (Ver todos)
Apple User Level 6 Super Combination Combination Topic Starter Poll Voter Poll Starter Level 5 Level 4 Level 3

Posta ai o teu URL.

Vai também a Configurações > Permalinks > e ve se o .htaccess que eles dizem para colocar está correcto.


SL