← WordPress

Problema com página de Tags

Lida 912 vezes

Offline

muiomuio 
Membro
Mensagens 324 Gostos 0
Feedback +1

Troféus totais: 23
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 4 Level 3 Level 2 Level 1 100 Posts 50 Posts

Já me chamaram à atenção para isto há bastante tempo mas apenas hoje de manhã tive oportunidade de tentar remediar o problema.

O meu blog http://muiomuio.net/ ao clicar nas tags dos artigos devolve a página de erro 404.
No entanto eu tenho uma página especifica para as tags tal como tenho para as categorias.

Ver: http://muiomuio.net/tag/twitter/

Neste caso para categorias tenho o category.php e para as tags tenho o tag.php.
No entanto é como se o ficheiro tag.php não existisse, já tentei tag-slug.php e o resultado é exactamente o mesmo.

o código do ficheiro tag.php é o seguinte:

Código: [Seleccione]
<?php get_header(); ?>

<div class="post">

<?php if (class_exists('breadcrumb_navigation_xt')) { ?>

<div id="topnav">

<?php if (!is_home()) {

// Display a prefix

// New breadcrumb object

$mybreadcrumb = new breadcrumb_navigation_xt;

// Apply options

$mybreadcrumb->opt['static_frontpage'] = true;

$mybreadcrumb->opt['title_home'] = 'Home';

$mybreadcrumb->opt['separator'] = ' &raquo; ';

$mybreadcrumb->opt['singleblogpost_category_display'] = true;

// Display the breadcrumb

$mybreadcrumb->display();

?>


</div>

<?php ?>

<?php if (have_posts()) : ?>

<ul>

<?php while (have_posts()) : the_post(); ?>

<li>

<a href="<?php the_permalink() ?>" rel="bookmark" title="<?php the_title(); ?>">

<?php the_title(); ?>

</a>
</li>

<?php endwhile; ?>

</ul>

<div class="navigation"><?php posts_nav_link('','','previous page'?> <?php posts_nav_link('','next page',''?></div>

<?php else : ?>

<div class="entry">

    <h2 class="center">Oops</h2>

    <p>Falta aqui algo...</p>

    <p>

    <h3>Artigos Recentes</h3>

    <ul><?php wp_get_archives('type=postbypost&limit=10'); ?></ul>

    </p>

</div><!-- entry -->
<?php endif; ?>
</div><!-- post -->

<?php get_sidebar(); ?>

Falta alguma coisa? Este código exactamente como está funciona correctamente com o category.php