← SMF

Erro de PHP (SMF)

Lida 5985 vezes

Offline

Thomato 
Membro
Mensagens 4125 Gostos 2
Feedback +2

Troféus totais: 28
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Boa tarde.

Fiz uma mudança das várias contas de alojamento para um sistema de revenda...

Tinha o subdominio digiart.emrede.net na pasta digiart do servidor. (Podem ver agora aqui: http://13studiohost.net/~emrede/digiart/ )

Criei a conta digiart.emrede.net no WHM do novo servidor

Depois pus em .tar no cpanel a pasta digiart do antigo servidor e uploadei os ficheiros para a pasta principal.

Fiz backup da BD e restaurei...

Alterei o que se tinha que alterar no Settings.php ...


Agora dá este erro:
Código: [Seleccione]
Fatal error: require() [function.require]: Failed opening required '/home/emrede/public_html/digiart/SSI.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/digiart/public_html/Sources/Load.php(1730) : eval()'d code on line 1

@ http://digiart.emrede.net/

Alguém me pode ajudar?

Obrigado
Offline

narg 
Membro
Mensagens 265 Gostos 0
Feedback +2

Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

Vê o ficheiro configuration que deve ter os caminhos errados

/home/emrede/public_html/digiart

deve ser algo

/home/digiart/......
Offline

Thomato 
Membro
Mensagens 4125 Gostos 2
Feedback +2

Troféus totais: 28
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Alterei o que se tinha que alterar no Settings.php ...[/b]

Já alterei isso :S
Offline

narg 
Membro
Mensagens 265 Gostos 0
Feedback +2

Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

que tens em /home/digiart/public_html/Sources/Load.php
na linha 1730 ?
Offline

cenourinha 
Elite
Mensagens 4094 Gostos 21
Troféus totais: 34
Trófeus: (Ver todos)
Mobile User Apple User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4

Remove a função require que tens la no ficheiro.
require()

Provavelmente estás a incluir um ficheiro que não existe no teu servidor.
Offline

narg 
Membro
Mensagens 265 Gostos 0
Feedback +2

Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

O ficheiro SSI.php é necessário ...
Offline

Thomato 
Membro
Mensagens 4125 Gostos 2
Feedback +2

Troféus totais: 28
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Agora apaguei a conta para experimentar fazer doutra maneira.

Vou transferir de uma conta para a outra através da função que o CPANEL dá :)
Offline

narg 
Membro
Mensagens 265 Gostos 0
Feedback +2

Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

O erro de php nada têm a haver com a maneira de transferir a conta, apenas têm a haver que algures no código ou na BD ainda têm referencia aos caminhos antigos ...
Offline

Henrique Mouta 
Equipa
Mensagens 1189 Gostos 3
Troféus totais: 31
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4 Level 3

Thomato, o problema está onde o narg disse.
Offline

Carlos Gandra 
Administrador
Mensagens 3081 Gostos 97
Feedback +1

Troféus totais: 34
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Poll Starter Level 5 Level 4

Já experimentaste usar o Repair settings?
Offline

Thomato 
Membro
Mensagens 4125 Gostos 2
Feedback +2

Troféus totais: 28
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Um dos problemas já sei qual era.

Não tinha feito bem o download da pasta.

Mas o problema continua....

Isto demora cerca de 1h a uploadar e a seguir já faço o que disseram :)
Offline

narg 
Membro
Mensagens 265 Gostos 0
Feedback +2

Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1 100 Posts

Estás a fazer upload zipado ?

É que ficheiro a ficheiro demora seculos :-P
Offline

Thomato 
Membro
Mensagens 4125 Gostos 2
Feedback +2

Troféus totais: 28
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Sim, tou a fazer em formato TAR...

Faltam 40m
Offline

cenourinha 
Elite
Mensagens 4094 Gostos 21
Troféus totais: 34
Trófeus: (Ver todos)
Mobile User Apple User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4

Põe um index no site ou tira o backup da home... -_-'
Offline

Thomato 
Membro
Mensagens 4125 Gostos 2
Feedback +2

Troféus totais: 28
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Tive que sair de urgência e feito parvo deixei lá aquilo.

http://digiart.emrede.net/

Já funciona...

Já o tema :S Mas está tudo correcto :S