← Desenvolvimento

Ajuda com RSS

Lida 1533 vezes

Offline

raugusto 
Elite
Mensagens 3145 Gostos 33
Feedback +13

Troféus totais: 31
Trófeus: (Ver todos)
Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Pessoal, uso o cute news no meu site www.tuning.online.pt na nova versão. Esta versão codifica RSS. O problema é que não atinei com as codificações.

consigo melhores resultados com Character Encoding (default: UTF-8)=iso-8859-1 e com a language = pt-PT. No entanto assim não me aparecem os &

Se puzer UTF-8 ainda fica pior e não aparecem os caractéres acentuados ingleses. Alguem sabeajudar? tem alguma coisa a ver com o servidor?

http://feedvalidator.org/check.cgi?url=http%3A%2F%2Ftuning.online.pt%2Ftolnews%2Frss.php

nesse feed validator aparece um warning a reportar diferenteças para o servidor.
Offline

fpware 
Fundador
Mensagens 15318 Gostos 6
Troféus totais: 38
Trófeus: (Ver todos)
Linux User Mobile User Level 6 Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Poll Starter Level 5

Citar
Your feed appears to be encoded as "UTF-8", but your server is reporting "US-ASCII"


Efectivamente isto parece ser um problema...

Ao ler directamente o teu feed aparece outro problema:

Citar
XML Parsing Error: not well-formed
Location: http://tuning.online.pt/tolnews/rss.php
Line Number 14, Column 21:<title>Novidades H&R para o novo Leon</title>
--------------------^


Neste thread, será que encontras resposta:
http://cutephp.com/forum/index.php?showtopic=10040 ?