← WordPress

Problema com navegação

Lida 1073 vezes

Offline

Thomato 
Membro
Mensagens 4125 Gostos 2
Feedback +2

Troféus totais: 28
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Tenho um problema na navegação em Wordpress!

Criei um Widget de texto e escrevi um código:

Citar
<center>
<a href="site"><img src="menu/inicio.PNG" border="0"></a><br>
<a href="site/sobre"><img src="menu/sobre.PNG" border="0"></a><br>
<a href="site/contacto"><img src="menu/contacto.PNG" border="0"></a><br>
</center>

<br><br>

Era suposto isso aparecer em todas as páginas... Mas só aparece na Home...  Quando entro noutra página aparece o titulo do Widget mas não aparece o conteúdo. Se for texto normal já aparece.

Experimentei colocar o menu no Header (Ficava bem) mas passa-se o mesmo! Texto aparece, imagens não!
Até editei o ficheiro sidebar.php e passava-se o mesmo :x


Alguma solução?

Ficaria muito grato
Offline

labfreak 
Membro
Mensagens 408 Gostos 0
Troféus totais: 27
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

instala o Daiko's Text Widget

activa (coloca o widget onde quiseres) e colocas la o codigo
Offline

Thomato 
Membro
Mensagens 4125 Gostos 2
Feedback +2

Troféus totais: 28
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2

Eu sou muito estúpido mesmo.

Eu uso o Mozilla. E como devem saber, o Mozilla não mostra as imagens quando não as consegue encontrar (Ao contrário do IE que mostra um quadrado com um 'X')

E o problema era que na página inicial ele conseguia ir buscar à directoria imagens os ficheiros mas quando entrava noutra secção ele ficava meusite.com/site/nomedapágina
E já não conseguia ir buscar os ficheiros porque estavam numa directoria anterior..

Tive que escrever o link completo nas imagens :D

Mas obrigado pela sugestão LabFreak :D