← HTML + CSS

[CSS] Imagens sem links

Lida 1778 vezes

Offline

CasaTuga 
Membro
Mensagens 397 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Num blog que estou a fazer inseri uma div com umas imagens do RSS, technorati, stumble e mais uns quantos à direita do blog. (em cima)baixo do background.

Eu no CSS já pus o z-index em 1 mas o background continua á frente....

HTML
Código: [Seleccione]
<div class="Subsc">
<a href="http://Link RSS Feed"><img src="http://localhost/ct/wp-content/uploads/2008/12/feeds_512x512.png" alt="" /></a>
<p><a href="http://localhost/ct/wp-content/uploads/2008/12/canal-youtube.png"><img  src="http://localhost/ct/wp-content/uploads/2008/12/canal-youtube.png"/></a>
<a href="Link Perfil FaceBook"><img  src="http://localhost/ct/wp-content/uploads/2008/12/perfil-facebook.png" /></a>
<p>
<a href="Link Perfil StumbleUpon"><img src="http://localhost/ct/wp-content/uploads/2008/12/stumbleupon.png" /></a>
<a href="Perfil do Tecnhorati"><img src="http://localhost/ct/wp-content/uploads/2008/12/technorati.png" /></a>
</div>

CSS
Código: [Seleccione]
.Subsc
{
float: right;
border: 0px;
margin: 20px;
z-index:1;
}

Alguém me consegue ajudar ?


Edit:

O site que estou a fazer é tipo isso que fiz no photoshop
Tem um gradiente em cima, eu pus o código na linha a seguir onde o gradiente é "chamado"
Offline

CasaTuga 
Membro
Mensagens 397 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

Basicamente:
Acho que a div dos links sociais ficou por trás do background
Ja tentei o z-index mas parece não ser daí que o problema vem

Alguem sabe de onde poderá ser o problema ?
Offline

Gonçalo Martins 
Membro
Mensagens 229 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

.Subsc
{ position:relative;
   float: right;
   border: 0px;
   margin: 20px;
   z-index:1000;
}
Offline

CasaTuga 
Membro
Mensagens 397 Gostos 0
Troféus totais: 26
Trófeus: (Ver todos)
Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3 Level 2 Level 1

 :obrigado:
Já funciona


Parece que o problema era da interpretação do css pelo FF3 e o Chrome (So por acaso era os que estava a usar enquanto fazia as cenas no site)
(Estão com 71 e 79 no Acid3)

NO Opera e o IE7 estavam a dar