← HTML + CSS

HTML+CSS+PHP - Borda Azul em Imgens com hiperligações

Lida 3259 vezes

Offline

Diogo92 
Membro
Mensagens 62 Gostos 0
Feedback +1

Troféus totais: 21
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Level 4 Level 3 Level 2 Level 1 50 Posts 10 Posts First Post

É o seguinte, tenho uma imagem gerada por PHP que tem um link, mas que fica com uma borda azul. Já tentei utilizar divs e depois css, mas sem resultado. Já tentei colocar a indicação border: 0px directamente no código, mas também não funcionou.

Aqui fica o código:

CSS

Código: [Seleccione]
#content{
width:400px;
        float: left;
border: 0px;
}

#content a {
border: 0px;
}

#image_post {
margin-left: 10px;
margin-right: 5px;
margin-bottom: 10px;
margin-top: 5px;
}

#image_post a {
border:0px;
}

HTML + PHP

Código: [Seleccione]
<div id="image_post">
<a href="<?php the_permalink() ?>"><?php the_post_thumbnail(); ?></a>
</div>

A imagem é a gerada pelo código: <?php the_post_thumbnail(); ?>

Obrigado, pela ajuda :)

Offline

João Simões 
Membro
Mensagens 1177 Gostos 5
Feedback +1

Troféus totais: 32
Trófeus: (Ver todos)
Apple User Super Combination Combination Topic Starter 50 Poll Votes 10 Poll Votes Poll Voter Level 5 Level 4 Level 3

e border:none?
Offline

Pedro Lopes 
Beta tester
Mensagens 3568 Gostos 18
Feedback +6

Troféus totais: 32
Trófeus: (Ver todos)
Level 6 Windows User Super Combination Combination Topic Starter 10 Poll Votes Poll Voter Level 5 Level 4 Level 3

Tenta:

#image_post img {
 border: none;
}
Offline

Diogo92 
Membro
Mensagens 62 Gostos 0
Feedback +1

Troféus totais: 21
Trófeus: (Ver todos)
Super Combination Combination Topic Starter Level 4 Level 3 Level 2 Level 1 50 Posts 10 Posts First Post

Funcionou, obrigadão aos dois.  :grin: